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1.1 Introduction

The TelStrat Application Line Card (TALC) is an Nortel Networks referenced Intelligent Peripheral Equipment

(IPE) line card that provides connectivity between telephones and the Engage Record server to allow for call

recording. Install the TALC in the host PBX to provide service for up to 32 telephones.
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1 TALC - PBX Compatibility

Physical Features

The single-wide, 16-channel version of the TALC (740-01060-01) provides service for up to 16 telephones.

The double-wide, 32-channel version of the TALC (740-01060-02 or 740-01060-03) provides service for up to 32

telephones.

Both versions emulate a standard digital line card (XDLC) in the PBX.

PBX Hardware Compatibility

Meridian 1 PBXs

The TALC is compatible with the following Meridian 1 PBXs:

l Meridian 1 PBX 11, 11C – Cabinet, 11C – Chassis, 11E, 51C, 61C, 71C, and 81C. The TALC is compatible with

the 11(C)-mini with the following limitations:
o The 16-port TALC is supported in slots 1—3 in themain chassis.

o The 16-port TALC is supported in slots 7—10 in the expander chassis.

o The 32-port TALC is supported in slots 1 or 2 in themain chassis, with maximum of one TALC.

o The 32-port TALC is supported in slots 7, 8, or 9 in the expander chassis, with a maximum of two

TALCs.

o Older Meridian 1 PBXs that are upgraded with IPE modules.

NOTE: Since the 32-port TALC requires two backplane connections, it cannot be assigned to slot 10, because

this slot provides only one backplane connection.

NOTE: NT8D37AA IPE cabinets use split-slot wiring. If you have one of these cabinets, the TALCs can only

reside in slots 0, 4, 8 or 12 unless the slot is rewired. To use any other slot, rewire part of the IPE backplane

using Nortel cable NT8D81AA (A0359946).
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CS 1000 PBXs

To obtain the TALC requirements for Communication Server 1000 (CS 1000) PBXs, contact the TelStrat dis-

tributor.

The TALC required packages for Communication Server 1000 are:

l X11 packages 0 and 121 contain all the four required Classes of Service.
o Package Number 0 (Basic Call Processing Package) includes FLXA, VCE, and WTA.

o Package Number 121 (Station Camp-on) includes CPTA.

l The following four feature sets of release 25.30 include both packages:
o NTSK11CQ: Meridian 1 PBX 11C General Business Feature Set.

o NTSK11DQ: Meridian 1 PBX 11C Enhanced Business Feature Set.

o NTSK11EQ: Meridian 1 PBX 11C Enterprise Business Feature Set.

o NTSK11FQ: Meridian 1 PBX 11C NAS/VNS Feature Set.

CS 2100 PBXs

For new CS 2100 PBX installations of the TALC card, the CS 2100 PBX does not accept a TelStrat Product Num-

ber (Product Engineering Code or PEC) longer than eight characters. Therefore, map the IPE PEC table of the

TALC PEC codes to the XDLC before provisioning the TALC channels. Use the following TALC PEC codes to

accomplish themapping:

l T0106001 (TALC 16-channel).

l T0106002 (TALC 32-channel -Meridian 1 PBX Option 11).

l T0106003 (TALC 32-channel - IPE).

An example data entry of this type is:
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IPE vs. Meridian 1 PBX 11

The double-wide TALCs for IPE shelves and Meridian 1 PBX 11 cabinets differ slightly to accommodate differing

card slot dimensions. Each variation has its own order code, as outlined in the following table:

Location Order Code

Meridian 1 PBX Option 11 Cabinet 740-01060-02

IPE Shelf 740-01060-03

Regardless of order code, themotherboard of the 32-channel TALC is the same circuit pack that is used for the

16-channel TALC. This circuit pack conforms to the Common Features Specification for IPE line cards. It is

shown in the illustration on page 5. The faceplates for both the 16-channel and 32-channel versions are shown

in the illustration on page 6.

NOTE: Although TelStrat discontinued the double-wide, 32-channel TALC in May 2008, existing deployments

of the 32-channel TALC continue to receive TelStrat’s full support.
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1 TALC - PBX Software Compatibility

The TALC is compatible with the following software:

l Meridian 1 PBX software release 17 through 22when using TALC firmware release 1_02_00cb6.

l Meridian 1 PBX software release 23 or higher.

l CS 1000 PBX software release 2 or higher.

l CS 2100 PBX software releaseMSL12 or higher.

Note: You can use the TALC with Release 15 or higher, but the data port configuration is slightly different.

Refer to the following table for further details.

Configure the ports on the TALC as a Meridian Communication Adapter (MCA) or an Analog Telephone

Adapter (ATA) with the first line able to make and receive data calls. To configure data ports as MCA or ATA,

make the following settings in LD 11:

Meridian 1 Software Release Setting

15 - 17 CLS prompt = DTA

18 or higher DTA0 output = ATA / MCA

For further details, refer to the section on LD 11 in theMeridian 1 PBX X11 I/O Guide (NTP 553-3001-400).

Tandem Digit Display (TDD) Feature

To perform DN Discovery on a feature key other than feature key 0 of any TALC connected telephone, the

Meridian 1 PBX housing the TALC must run software Release 23 or later.

Meridian 1 PBX software Release 23 introduced Tandem Digit Display (TDD) class of service. From a TALC per-

spective, TDD enables administrators to configure DNDiscovery such that the TALC Extension to Dial can be a

feature key other than feature key 0. For detailed information on DNDiscovery and the TALC Extension to Dial

field, refer to “TALC System Configuration” on page 55.
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Configure each port on the TALC from the host PBX database as if it were a standard digital line card (XDLC).

An integrated Voice over Internet Protocol (VoIP), 10BaseT Ethernet interface sends the voice and signaling

traffic to the Engage Record server as packets.

Upload TALC firmware through a customer-provided Trivial File Transfer Protocol (TFTP) server installed on the

administration PC, through a 10BaseT Ethernet connection.

Note: Although TelStrat discontinued the double-wide, 32-channel TALC in May 2008, existing deployments

of the 32-channel TALC continue to receive TelStrat’s full support.

1.2 TALC LED Indicators

The red Maintenance LED on the faceplate indicates the basic health of the TALC, just as with all other IPE line

cards. Under normal conditions:

l Maintenance LED lights under firmware control at power up.

l Blinks three times after a successful self-test

l Remains lit until the host PBX enables the TALC, then it goes out.

l If the host PBX disables the TALC, theMaintenance LED comes on and stays on.

l If, after the TALC passes its self-test, theMaintenance LED comes back on, ensure that the card is enabled

(refer to host PBX documentation for the correct procedure). If the TALC is enabled and the LED remains

on, there is a problem at the host PBX.

l If the LED blinks repeatedly at one-second intervals, reseat the TALC by lifting the ejector tabs outward and

pulling the card toward yourself. This action breaks the connection between the TALC and the host PBX

backplane. After breaking this connection, reinsert the card completely into its slot and push the ejector

tabs back to the faceplate, locking the card in place. If the TALC still does not complete a successful self-

test, it must be replaced.

Three other faceplate LEDs monitor transmit and receive activity and collisions over the TALC’s Ethernet inter-

face. The 16- and 32-channel TALC faceplates are shown on page 6with the function of each LED labeled.
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NOTE: Although TelStrat discontinued the double-wide, 32-channel TALC in May 2008, existing deployments

of the 32-channel TALC continue to receive TelStrat’s full support.

TALC Faceplates (16 channel and 32 channel)

1.3 TelStrat DSP 8 Modules

Add up to four TelStrat DSP 8modules (740-01062-01) to the TALC to extend the system’s voice processing

capacity.

Each TelStrat DSP 8module provides an additional eight channels of packet voice recording. The image below

shows the locations of digital signal processor(DSP) expansion slot pairings on the TALC.

The following image shows a TelStrat DSP 8module that holds two DSP devices. Up to three TelStrat DSP 8

modules can be added to the TALC to increase the line card’s call processing capability by up to 32 channels.

TALC Motherboard
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TelStrat DSP 8module (740-01062-01)

1.4 TALC Multi-IO Cable-Enhanced

The TALC Multi-I/O Cable–Enhanced (800-00072-03) gives you access to the TALC’s call processing capabilities.

This cable provides the following connections:

l 10BaseT for VoIP access to the corporate Ethernet

l RS-232 for Engage Record administration and maintenance through the serial port
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l 10BaseT for maintenance of the host PBX over the host PBX’s internal Ethernet

l TCM for linking to each workstation telephone

NOTE: The TALC supports only half-duplex 10BaseT Ethernet.

The TALC Multi-I/O Cable-Enhanced connectors are described as:

Connector
Labeled Connector Type Transmits Connects to

P1 female 25-pair connector all signals I/O panel

P2 male RJ-45 connector 10BaseT sig-

naling

CLAN Ethernet

(customer LAN on

the network)

P3 female DB-9 connector RS-232 sig-

naling

serial port con-

nection for main-

tenance and

administration

P4 male RJ-45 connector 10BaseT sig-

naling

ELAN Ethernet

(PBX's embedded

LAN)

P5 male 25-pair connector TCM sig-

naling

cross-connect to

local phones

NOTE: If you are using a double-wide, 32-channel TALC, insert connector P1 into the socket for the first of the

two card slots occupied by the TALC.

The length of this cable, from the termination end of connector P1 to the termination end of any of the other

plugs, is 2 feet (0.6meters).
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TALC Multi-I/O Cable–Enhanced (800-00072-03)

1.5 Meridian Digital Telephone Hardware Compatibility

The TALC is compatible with the following Meridian digital telephone equipment:

Models Modules

M2006 (see note 1) M3310 add-on

modules

(see note

5)

M2008D M3820 key

expan-

sion mod-

ules
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Models Modules

M2008HFD M3901 (see note 1)

M2216D M3902 (see note 3)

M2616D M3903 (see note 4)

M2616CT (see note 2) M3904

M3110 M3905

1. M2006 and M3901 digital telephone sets are not capable of displaying local recording messages. There

may be a loss of call record information as these telephone sets do

2. ii. Nortel has discontinued theM2616CT cordless telephone.

3. Engage Record Feature keys are functional on theM3902 Phase I digital telephone set. However, the labels

on the telephone are blank after configuring the feature keys. You must manually label the feature key on

theM3902. Refer to “Configuring a TALC Port on page 70 for details on configuring Engage Record feature

keys

4. TheM3903 Phase I digital telephone set’s MessageWaiting key fails once TALC has registered the port as a

Phase II digital telephone set. This can occur when mixing Phase I and Phase II digital telephones sets.

5. Add-on modules include key based add-on modules (KBAs) and display-based add-on modules (DBAs) for

M39xx sets.
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1.6 Meridian Digital Console Hardware Compatibility

The TALC is compatible with theM2250 Console telephone. However, theM2250 Console telephone does not

display the following Engage Record feature toggles:

l Call Captured and Call Capture Stopped = ECS toggle

l Recording and Recording Stopped = EREC toggle

l Recording Disabled and Recording Enabled = RDIS toggle

TheM2250 Console telephone requires two Terminal Numbers (TNs) for voice and signaling connection and

up to three TNs to supply additional power to the telephone set for the add on modules. Configure these addi-

tional TNs as PWR type on the PBX. For Engage Record, TALC only supports the two main TNs for theM2250

configuration. TelStrat does not currently support M2250 Console telephone Auxiliary Power on the 16- or 32-

channel TALC. You must configure additional TNs on an XDLC located in the same PBX. Proper wiring has to be

established from the TALC and the XDLC. This configuration also preserves TALC ports for recording purposes.

TelStrat recommends that you assign a maximum of threeM2250 Console telephones to a single TALC.

However, if you deploy multipleM2250s across multiple TALCs, TelStrat recommends that you distribute

them evenly across the TALCs to avoid the possibility of a single point of failure.

1.7 Operational Characteristics

The TALC provides a number of unique features that distinguish Engage Record from other voice recording

products.

These features include:

l Port sharing.

l Packet voice processing.

l Transparent operation.

l Meridian digital telephone equipment compatibility.

Packet Voice
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All connections to the TALC support G.711 and G.723.1 (6.4 kbps) voice compression standards. You can

assign different voice compression algorithms to individual ports(refer to “TALC Port Configuration” on page

68.) This feature allows you to configure different voice quality for different users.

Transparent Operation

The host PBX interacts with the TALC as though it were a standard digital line card(XDLC). Aside from

enhanced functionality, there is no difference in the operation of a telephone connected to a TALC and the

operation of a telephone connected to an XDLC. Additionally, the TALC can operate in XDLC-only mode, if no

Engage Record server is present.

1.8 Environmental Requirements

The TALC withstands the following environmental conditions without any performance degradation or dam-

age.

Note: In this section, the phrase short term equates to 72 consecutive hours with a maximum of 15 days per

year. The temperature ratings are for the environment of the circuit and not the total system.

Specification Minimum Maximum

Operating Temperature - Normal (ambient) 0° C (32° F) 60°° C (140° F)

Operating Humidity - Normal 5% (non-condensing) 95% (non-condensing)

Storage - Recommended Temperature -40° C (-40° F) 70° C (158° F)

Storage - Relative Humidity 5% RH (non-condensing) 95% RH (non-condensing)
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2 Installation

This section describes the steps to be taken to successfully install a TALC.

2.1 General Safety

This section describes general safety guidelines recommended by TelStrat and tools needed for line card

installation. Follow these safety guidelines whenever you perform installation or maintenance tasks on the

TALC.

WARNING: Risk of data loss or equipment damage: Electrostatic discharge (ESD) affects the performance of

system components, such as TelStrat DSP 8modules and TALCs. It can seriously damage such components

and decrease their useful life. Be certain you are properly grounded before handling them.

Required Tools

Installation of the TALC and installation or replacement of TelStrat DSP 8modules requires the specific items.

First-time installation or maintenance upgrade will require those items listed under Software Installation or

Upgrade.

Hardware Installation:

l Antistatic ESD wrist strap (recommended)

l Phillips-head screwdriver

l Slot-head screwdriver

l Pen or pencil for noting cable lengths and labeling cables

l Cable tie wraps

l Cable identification labels

l Tapemeasure

Installation or Upgrade software:
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l Downloaded from the TelStrat Support Portal.

l Engage Record CD-ROM.

2.2 Installation Overview

For a successful installation, the steps to complete the installation are:

1. Assemble and Install the TALCs into the IPE module or Meridian 1 PBX 11 cabinet.

2. Connect a TALC Multi-I/O Cable-Enhanced to each slot of the cabinet containing a TALC.

3. Initially, install the TALC Configuration Manager software on a laptop computer.

Note: Installing the TALC Configuration Manager software on a laptop computer allows initial con-

figuration of the TALC(s) without relocating the Engage Record server to perform the configuration.

TelStrat recommends also installing the TALC Configuration Manager software on the Engage Record

server for future configuration changes.

4. Connect a serial cable from the serial port of the laptop to the TALC Multi-I/O cable.

5. Open and logon to the TALC Configuration Manager application.

6. Log onto the TALC using the Serial Connection.

7. Configure the TALC.

8. Reset the TALC.

9. Connect the TALC Multi-I/O Cable-Enhanced RJ-45 plug labeled “external” to the data switch using a CAT 5

cable.

10. Repeat steps 1-9 for each TALC.

2.3 Installing TelStrat DSP 8 Modules

Install TelStrat DSP 8Modules in the expansion slots on the TALC. Adding TelStrat DSP 8Modules to the TALC

increases the number of telephone calls that can be recorded. To add TelStrat DSP 8Modules to the TALC:
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l Determine the number of channels that you want to record.

l Install TelStrat DSP 8Modules.

Determining How Many TelStrat DSP 8 Modules to Add

Allow one DSP channel on the TALC for each telephone call to be recorded. The TALC comes with sufficient on-

board DSP resources to record up to eight simultaneous telephone calls. In addition, DSP expansion slots

enable the addition as many as three TelStrat DSP 8Modules (740-01062-01) to the TALC.

Each TelStrat DSP 8module increases the voice processing capabilities of the system by eight channels. This

means that an Engage Record system can simultaneously record up to 16 simultaneous conversations with

just one TelStrat DSP 8module added to the TALC, or up to 32 conversations with three TelStrat DSP 8mod-

ules added to a32-channel TALC.

Once ordered and received from TelStrat, the TelStrat DSP 8modules can be installed.

Handling TelStrat DSP 8 Modules

Be careful an follow the guidelines for ESD protection while handling DSPs and TALCs.

WARNING: Risk of data loss or equipment damage: Electrostatic discharge (ESD) affects the performance of

system components, such as TelStrat DSP 8Modules and TALCs. It can seriously damage such components

and decrease their useful life. Be certain you are properly grounded before handling them.

Installing TelStrat DSP 8 Modules

To install TelStrat DSP 8Modules:

1. become grounded with an approved wrist or heel strap before handling TelStrat DSP 8Modules or TALCs.

2. Clear a flat, static-free work area with sufficient space to hold all TALC and TelStrat DSP 8modules.

3. With the TelStrat DSP 8modules still in their antistatic bags, place them in the work area.

4. Remove the TALC from the host PBX and place it in the work area.
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5. Remove a TelStrat DSP 8module from its antistatic bag, holding it by its edges, with the insertion tabs

facing down.

6. Insert the tabs into a pair of expansion slots on the TALC. The tabs should snap into place when fully inser-

ted. Visually inspect each tab to make sure that there is no gap between themodule and the top of the

expansion slot, thus ensuring that themodule is fully inserted.

2.4 Installing a TALC into a PBX

Whether the system consists of one or multiple TALCs, the installation process is the same for each one, as fol-

lows:

1. Locate the correct PBX cabinet or IPE module, shelf and card slot for the TALC.

2. Insert the TALC into its assigned card slot. Ensure that the lower tips of the ejector tabs are positioned

properly inside the front edges of the shelf.

3. Lock the TALC into position by pushing the handles toward one another until they touch the faceplate. If

there is inappropriate resistance, stop and reposition the card.

4. Look for the Self-Test and Maintenance LEDs to operate.

5. Verify that the host PBX recognizes the presence of the TALC. (Refer to the documentation specific to the

host PBX for exact procedures to verify the presence of an XDLC.)

2.5 Verifying the Installation

Once you have finished the installation and cable connection of the TALC, verify the installation.

Indications of Proper Installation

When a TALC is placed in its slot, it automatically performs a self-test. A successful self test indicates proper

installation. The following behaviors by theMaintenance LED confirm a successful self-test:

l blinking three times.

l turning off.

l remaining off (if enabled by the switch).
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Note: Refer to LED Indicators in this guide for more details.

Indications of Proper Cable Connection

The ability to successfully log on to the TALC through TALC Configuration Manager software indicates proper

cable connection to the TALC.

2.6 Install TALC Configuration Manager Software

The TALC Configuration Manager software is installed on the administration workstation, not the server. Use

this software to configure and administer the TALC.

Download Engage Software

Engage product software is available for download from the TelStrat Support Portal. Use this link DOWNLOAD

ENGAGE SOFTWARE.HTM to get instructions for downloading and extracting Engage software from the Install -

Obtain Engage Software Administration Guide.

Configuration Manager software

After downloading and extracting the software:

1. Open these folders: C:\EngageSoftware\TALC\TALC Current Release\TALC-1_05_02.20\TALC-1_05_

02.20\GUI.

2. In the TALC folder, double-click on setup to launch the TALC Configuration Manager installation wizard.

TheWizard splash screen appears while setup is running.
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3. When theWelcome screen appears, click Next.

4. On the License Agreementwindow, click on I accept the terms in the license Agreement button and click

Next.
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5. At the Setup Typewindow, click on the Complete button and click Next.

6. Click Install on the Ready to Install the Program window.
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7. The install takes a very short time. When complete, click Finish on the Completedwindow.

2.7 Initial Configuration of TALC

Each TALC requires an initial configuration. The TALC Configuration Manager program has a Configuration

Wizard option used to input theminimum configuration information needed for establishing com-

munications between the TALC and the Engage Record server.

The Configuration Wizard provides only a subset of the full configuration settings available in Configuration

Manager. Using the Configuration Wizard, the TALC can be up and running within ten minutes.

The Configuration Wizard can be used in an unconnected (offlinemode) or while connected and logged onto

the TALC (onlinemode).

The Initial Configuration

The Configuration Wizard performs an initial configuration of the TALC for the following:

l TelStrat Application Line Card IP addressing, including:
o IP address of the TALC,

o Subnet mask,

o Default gateway,

o IP address of the Engage Record server to which the TALC connects.
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l DNDiscovery, including:
o scheduling parameters,

o specific times and dates.

NOTE: Make sure the IP information is correct and valid for establishing a Telnet session with the TALC.

NOTE: Any changes to initial settings made after the initial configuration aremadewith the TALC Con-

figuration Manager, not the Configuration Wizard.

Start the TALC Configuration Manager

With the software installed on the administration PC:
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1. Use the PC's Startmenu to launch the program: Start » All Programs » TALC Configuration Manager.
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2. The TALC Configuration Manager opens and displays the Local User Authentication dialog box. Enter the

following:
a. Login Name: Enter admin.

b. Password: Enter root.

3. Click on theOK. The TALC Configuration Manager dialog box displays a successful log on.

4. Click on theOK button in the Login Successful box to exit the logon window. The TALC Configuration Man-

ager screen appears and displays a fewmenu commands on the top navigation bar.

Start the Configuration Wizard
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TALC configurations are stored on the TALC circuit pack in flash memory. The initial configuration of a TALC is

completed one of two ways:

l Creating a NEW configuration file.

l Selecting an existing configuration file.

Start the wizard:

1. On the TALC Configuration Manager, click the Configuration Wizard command. The Configuration Wizard

introductory screen pops up.

2. Review the screen's information and click on Next. The Configuration Wizard - TALC graphic screen dis-

plays:

Create a NEW Initial TALC Configuration
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On the Configuration Wizard screen, there are five action buttons that perform different tasks. The buttons

are described as:

a. Open File button: Used to load an existing configuration file into the TALC's Flash memory.

b. Next button: Used to create a NEW configuration file for a TALC.

c. Back button: Used to review the information on a previous screen.

d. Close button: Used to stop the TALC Configuration Wizard.

e. Help button: Used to view information about the fields on the current screen.

Initial Configuration Addressing

To create an initial, NEW TALC configuration file, click on Next and enter this information into the Con-

figuration Wizard - TALC window fields:

a. Set the unique Unit ID of the unit: Select a unique number (1 through 254) to identify the TALC being

configured (ex. 1). The unit ID assigned to the TALC must be unique from the unit IDs assigned to other

TALCs that communicate with the same Engage Record server. This allows a single Engage Record

server to record calls from multiple host PBXs simultaneously.
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NOTE -- the TALC card Unit ID is also used in the Engage client, when adding ports. The port num-

ber will be "00XX", where the XX is the Unit ID number.

b. Enter a Node Name to recognize the unit: Enter a name that describes the TALC being configured (ex.

RecorderTALC).

c. Enter the Engage Server IP address: Four boxes for the octets to contain the recording server

IP Address (ex. 192 168 142 228). The Engage Record server’s IP address must be statically configured.

The Engage Record server cannot be configured to obtain an IP address using Dynamic Host Control

Protocol (DHCP).

d. Enter the IP address of the unit: Four boxes for the octets to contain the TALC unit's IP address (ex.

192 168 152 188). If you do not have a valid IP address, enter the sample IP address: 5.6.7.8.

e. Enter the Local IP Mask of the unit: Four boxes for the octets of the subnet mask (ex. 255 255 255 0).

If you do not have a valid subnet mask, enter the sample subnet mask: 255.255.0.0.

f. Enter the Local IP Gateway of the unit: Four boxes for the octets to contain the IP address of the gate-

way between the TALC being configured and the network (ex. 192 168 152 200). If there is no router

between the TALC and the network, then the administration PC acts as the gateway. Enter the address:

1.2.3.5.
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Note: When entered and applied, this IP information allows administration of the TALC from any PC on

the network where a copy of the TALC Configuration Manager software resides.

DN Discovery Settings

a. Click theNext button. The Configuration Wizard - DN Discoverywindowdisplays. Complete the Con-

figuration Wizard DN Discovery screen fields as follows:

b. Frequency: Select how often the TALC is to automatically detect the host PBX-configured name and num-

ber assigned to each of its ports. Choose one of the following:
l Once a Day: If the TALC is to perform DNDiscovery daily.

l Once a Week: If the TALC is to perform DNDiscovery weekly.

l Once a Month: If the TALC is to perform DNDiscovery monthly.

c. Time: Set the time of day when the TALC will perform DNdiscovery in the time scroll box. Do one of the fol-

lowing:
l Highlight the hour displayed in the Time selection box and enter the hour or use the arrows at the

right side of the Time field to select the hour that the TALC is to perform DNDiscovery.

l Highlight theminute displayed in the Time selection box. Enter theminute or use the arrows at the

right side of the Time field to select theminute that the TALC is to perform DNDiscovery.

d. Day: If you select Once a Week, choose the day of the week when the TALC will perform DNDiscovery. In

the Day list box, choose the correct day of the week.

e. Date:If you select Once a Month, select the date when the TALC will perform DNDiscovery each month. In

the Date scroll box, choose the correct date.

f. Port: Choose the TALC port occupied by the DN in the DN field that follows. Engage Record uses this port

as a baseline in deriving DNDiscovery information.

g. Feature Key: Choose the feature key assigned to the TALC port and DN shown in the adjacent fields.

h. DN: Enter the directory number of the TALC port where calls are to be placed for DNDiscovery. Click Next.
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i. An information screen appears. Read the text regarding saving the configuration file.

Save the initial configuration file

There are two ways to SAVE the initial configuration file, depending on what process was used:

l Using an offline configuration process

l Using an online configuration process

Perform an OFFLINE configuration SAVE
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a. Click on the Save to File button. The Save As dialog box displays:

b. Specify the directory path and filename for this configuration.

c. Ensure the Save as type box shows the type of file as a Text File (*.TXT)

d. Click on Save. The previous Configuration Wizard information screen re-displays.

e. Click on Close to accept the configuration file just created. A dialog box will ask if another TALC is to be con-

figured. Click Yes if there are other TALCs to be configured or click on No to close this specific configuration.
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Note: This file can be opened in Configuration Manager, then send and save the file in the TALC’s Flash

memory at another time.

Perform an ONLINE configuration SAVE

If the TALC configuration file was created online (connectivity with the TALC established), it can be saved

into the TALC flash memory.

1. Click on the Save to Flash button. The Configuration Managerwill write the information contained

in the initial configuration file to the flash memory of the TALC being configured. If successful, the

messageData Sent Successfully appears.

Note: TelStrat recommends also saving the configuration to a separate file using the Save As

command. This creates a backup file of the initial configuration for use in the event the

TALC loses its flash memory.

2. Restart the TALC by using the Configuration Manager commands: Connect » System Reset »

Restart.

The TALC has theminimum information required for network connectivity.

2.8 Testing TALC Connectivity

After the initial configuration of the TALC is complete, test the connections to the TALC using the following

methods:



ag160414 Copyright © 2016, TelStrat International, Ltd.
All rights reserved.

36

l Check the system’s host-site connections to ensure basic IP Network connectivity.

l Perform a ping test. To do this test, the TALC must be physically connected to the IP network.

Check Ethernet Cable Connections

Check the following cable connections:

1. DB15 – RJ45 adapter at Plug 2 of the TALC Multi-I/O Cable–Enhanced is properly and securely joined to

Plug 2.

2. RJ45 plug of a CAT5 data cable leading to the system's Ethernet hub is securely seated in the RJ45 socket of

the DB15 – RJ45 adapter in previous step.

3. Other end of the CAT5 data cable discussed in the previous step is securely seated in the appropriate Eth-

ernet hub socket.

4. CAT5 data cable leading to the Ethernet network’s data router is securely seated in the appropriate Eth-

ernet hub socket.

5. CAT5 data cable leading from the system's Ethernet hub is securely seated in the data router’s socket.

NOTE: The TALC supports only half-duplex 10BaseT Ethernet

Performing a TALC Configuration Manager PING

Successful PINGs

A PING is a procedure whereby a device sends a packet set to a far end device on the network and having that

device respond by sending the packet set back to the sender. The time for the handshake is calculated and dis-

played. This ping tests the Ethernet connection from the Administration PC to the TALC unit and back.

1. From the TALC Configuration Manager menu bar, choose Tests » Ping. The PING Test dialog box displays,

similar to the following:

2. l IP Address: Enter the IP address of the TALC unit (far end) to ping (ex. 192 168 142 228).
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l Number of Cycles: Enter the number of times (ex. 1 to 100) to ping the TALC unit.

l Click on theOK button.

3. The PING test results screen appears showing the successful ping results. The Ethernet connection

between the administration PC and the TALC functions correctly.

4. Click on the Close button.

Unsuccessful PINGs:

If a PING is sent from the administration PC and no response from the TALC is received back, there exists and

issue on the Ethernet somewhere. Check the following:

1. Ensure the IP address, subnet mask, and default gateway are configured correctly.

2. PING the gateway address to see if the gateway responds.
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3. Check the Ethernet connections on the administration PC and the TALC.

4. Contact the data network administrator if the ping still does not work.

Once the TALC is recognized on the network (can be pinged), begin the configuration. TelStrat recommends

changing the passwords for logging on to the TALC Configuration Manager and the TALC at this time.
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3 Using Configuration Manager

The Configuration Manager

Configuration Manager is a Windows-based software application installed on an administration PC. Con-

figuration Manager allows configuration, administration and upgrades on the TALC.

Configuration Manager Connections

These tasks can be performed over either of the following connection types:

l 10BaseT Ethernet

l RS-232 serial

Windows PC Requirements

To be able to use the Configuration Manager, the administration PC must:

l be an IBM-compatible PC.

l use aWindows 2008, 2003, or XP Professional Server Edition operating system with theMicrosoft TCP/IP

networking component installed.

l be equipped with a CD-ROM drive.

l be equipped with a 10BaseT Ethernet interface card.

l have an available COM port to use the RS-232 serial port to establish a direct serial connection.

l be equipped with a pointing device, such as a mouse.

l useMicrosoft’s IP stack.

l have 64Mbytes of RAM for Microsoft Windows 2008, 2003, and XP Professional Server Edition.

l have 64Mbytes of available storage for Microsoft Windows 2008, 2003, and XP Professional Server Edi-

tion.

Note: Configuration Manager does not support any of theWin32 Server versions ofMicrosoft Windows.
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3.1 Starting-Viewing the Configuration Manager

The Configuration Manager software application is best viewed when themonitor settings are configured as

1024 by 768 pixels using Small Fonts at 96 dpi.

If using larger fonts, some fields and buttons might be hidden. Use the horizontal and vertical scroll bars to

view the hidden fields or buttons.

Start the TALC Configuration Manager

To start and log on to a Configuration Manager session:

1. From theMenu bar, choose Start » Programs » TALC Configuration Manager » TALC Configuration

Manager.
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2. The Configuration Manager screen opens and prompts for the login name and password. Enter the fol-

lowing:
a. Login Name box: Enter admin.

b. Password box: Enter root.

3. Click on theOK button. The TALC Configuration Manager dialog box displays a Local Login Successfulmes-

sage.

4. Click on theOK button in the Login Successful box to exit to the Configuration Setupwindow.

Note: This (root) is the default password. Change the password after installation, though TelStrat

recommends that you do not change the password until the Engage Record system is up and running.
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5. Click on theOK button.
l If the logon was successful, the dialog box disappears.

l If the login was unsuccessful, the system will require a re-attempt to login.
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3 System Tree and Property Sheets

The left pane of Configuration Manager lists the System Tree of Property sheet names you can access. To

expand the list of all the TALC property sheets, click on the plus (+) sign. To hide the list, click on theminus (-)

sign.

System Tree

With the System Tree expanded, three types of configurations become available with associated property

sheets found in the right pane.

To hide the system tree, choose View » System Tree from theMenu bar. The screen redraws itself showing

only the right pane and displaying the selected property sheet. To display the system tree again, choose View
» System Tree.

Property Sheets

When clicking on a configuration topic in the system tree (left-hand pane), the associated property sheet and

it's content appears in the right-hand pane. There are three Property Sheets for a TALC, including:

l TALC System Configuration,

l TALC IP Configuration,

l TALC Port Configuration.
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3.2 Command Buttons

Each property sheet listed in the first level of the TALC Configuration Manager system tree has Command But-

tons. The buttons used to send, retrieve accept new or default changes and to get help. The buttons are

defined as:

l OK: Use this button to accept any changes made to the displayed property sheet. This command stores

these values in a temporary file on the administration PC until the user is ready to update the TALC’s Flash

memory.

l Default: Click on this button to insert default values into every field in the displayed property sheet.

l Send: Use this button to update the buffer of the logged on TALC with the values currently on the dis-

played property sheet.

l Retrieve: Click on this button to display the saved configuration value for every field on the displayed prop-

erty sheet from the TALC’s local buffer. The TALC’s local buffer contains the last sent data.

l Help: Click on this button to view online Help for the displayed property sheet.
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3.3 Configuration Files Description

The TALC unit has three types of configuration files: event.dat (log file), *.txt (text file) and *.upg (upgrade file).

Configuration Manager: File Operations Diagram

TALC configuration information is stored in default locations to which Configuration Manager saves the TALC

configuration files on the Administration PC in theMy Documents folder. If needed, the user can choose a dif-

ferent folder for storage of configuration files in the dialog box. The default location for configuration file stor-

age is always the location of the last saved configuration file.

Types of Files
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File name File type When created and used

event.dat Log file The log (event.dat) file records all activities (and messages asso-

ciated with those activities) that you perform while running Con-

figuration Manager, such as:

l logging on to Configuration Manager

l logging on to a TALC (by serial or Telnet connection)

l logging off of a TALC

l performing configuration changes

l performing firmware upgrades

This file can be very useful when troubleshooting system prob-

lems. Technical support personnel may ask for this file.

*.txt Text file The text (.txt) file is created when you do one of the following:

l click on the Save to File button while running the Con-

figuration Wizard.

l click on File→ Save As while working in Configuration Man-

ager.

l choose Upload/Download →Download Configuration to

save a TALC’s configuration in a text file on the admin-

istration PC.

*.upg Upgrade file Use the upgrade (.upg) file when performing firmware

upgrades.
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3.4 Files Operation Description

The Configuration Manager performs different tasks and operations via menu commands. These commands

are used to save information to TALC buffers and flash memory, to retrieve information from a TALC, save cop-

ies of configuration files for backups as well as displaying TALC configuration content.

Regarding file operations commands:

Operation Description
OK When theOK button is clicked, the following occurs:

l The Configuration Manager checks any changes made for errors. Errors found

produce an error dialog box.

l Make the necessary changes to fix the errors and click on theOK button again.

Note: Always click on the OK button: 1) after making changes to a property sheet

2) before leaving a property sheet. To save the information, click on OK to accept

the changes. After clicking OK, send the changes to the TALC’s buffer using a

Send or Send All command. All changed data is LOST if not saved OR by leaving

the property sheet before saving the data.

Users can update the Flash memory on TALC by performing an Upload/Down-

load » Save to Flash operation from theMenu bar.
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Operation Description
File » Open When choosing File » Open from theMenu bar, a user can open a previously

saved configuration file. This is useful for preparing and storing configuration files

in a central location before they are deployed to a TALC in the Engage Record sys-

tem.

Note: The file typemust be text (.txt) to be opened.

File » Save As When choosing File » Save As from theMenu bar, Configuration Manager saves

the TALC’s configuration to a file on the administration PC. The user must specify

the file name and directory location after saving the file so it can be opened and

modified at a later time.

Notes: Configuration Manager saves the file as a text (.txt) file. If the Con-

figuration Manager closes without choosing File » Save As, all of the changes

made are lost.

Send When clicking on the Send button, Configuration Manager sends any changes

made on the displayed property sheet to the buffer of the logged-on TALC. If the

send is successful, this message is displayed:

Data Sent Successfully

TelStrat recommends clicking on theOK button before clicking on the Send but-

ton.

Note: The user must chooseUpload/Download » Save to Flash from theMenu

bar to save the changes to the logged-on TALC’s Flash memory.

Send All When choosing Upload/Download » Send All on any property sheet, changes

for all property sheets pertaining to the logged-onTALC are sent to the buffer on

the TALC connected to. If the send is successful, this message displays:
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Operation Description
Data Sent Successfully

Note: The user must chooseUpload/Download » Save to Flash from theMenu

bar to save the changes to the logged-on TALC’s Flash memory.

Retrieve When clicking Retrieve on a property sheet, the configuration stored in the buffer

of the logged-on TALC (the latest configuration information) displays in Con-

figuration Manager. If the retrieval is successful, this message displays:

Data Received Successfully

Save to Flash When choosing Upload/Download » Save to Flash from theMenu bar, the

information stored in the logged-on TALC’s buffer is saved to Flash memory. This

prevents the configuration from being lost if the TALC loses power. While in pro-

gress, this message displays in the status bar at the bottom of the screen:

Save to Flash

When the Save to Flash is completed, theData Stored to Flash dialog box dis-

plays.

Some changes require a restart of the TALC after saving the changes. If a restart is

necessary, Configuration Manager prompts the user to do so.

Note: Click on the Send button or chooseUpload/Download →Send All from

theMenu bar before choosing Upload/Download » Save to Flash. Perform a

Save to Flash as often as necessary to keep the configuration information safe.

Note: Do not ignore error messages in the Save to Flash process. If Save to

Flash fails, retry uploading and then Save to Flash again. If the problem persists,

check the file being uploaded and report the problem to TelStrat.
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Operation Description
Upload Con-
figuration

When choosing Upload/Download » Upload Configuration from theMenu bar,

Configuration Manager uploads the configuration file specified and writes the file

to the buffer on the logged-on TALC . Use this option if needing to restore or

replace an entire configuration. ChooseUpload/Download → Save to Flash from

theMenu bar to save the changes in the TALC’s Flash memory. If the Save to

Flash is not completed and a power loss occurs, all changes to TALC configuration

are lost and must be re-entered. While in progress, this message displays in the

status bar at the bottom of the screen.

Save to Flash in Progress

When the Save to Flash is complete, theData Stored to Flash dialog box displays.

Note: To upload a configuration file, the file typemust be text (.txt).

Note: To perform a configuration upload over the IP network, a TFT server applic-

ation must be running on the administration PC. TelStrat does not support

uploads over the serial port.

Note: Perform a Restart of the TALC after the Save to Flash operation.

Note: If the upload fails or aborts, confirm that the uploaded file is correct. If the

problem persists, contact TelStrat Customer Services for assistance.

Download Con-
figuration

When choosing Upload/Download → Download Configuration from theMenu

bar, Configuration Manager saves the configuration stored on the logged-on TALC

to a file on the administration PC. Use this option to create a backup copy of the

TALC’s configuration.

Notes: The downloaded file is saved as a text file (.txt).
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Operation Description

Note: If changes aremade BUT are not saved, that information is lost and must

be re-entered.

3.5 Working with Configuration Files

TALC configuration files aremanipulated using the Configuration Manager on an administration PC. The Con-

figuration Manager is used to:

l create a configuration file.

l open a configuration file.

l perform a configuration upload.

l perform a configuration download.

TALC configuration files contain information pertaining to PBX card slots, TALC IP addresses and ports. Each

TALC is a unique configuration.

Property sheets for each TALC contain configuration information and are completed, saved and sent to TALC

card buffers and flash memory.

Create a Configuration File

To create a new TALC configuration file:

1. Use the Administration PC Startmenu to launch the Configuration Manager.

2. Enter the required configuration information on each property sheet.

3. From theMenu bar, choose File » Save As. The Save As dialog box displays.
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4. Enter a descriptive name for the file. The file name should identify the type of configuration it contains.
l If the file contains a basic configuration that is to be used for TALC, enter template as the file name.

l If the file contains a configuration that is unique to a specific TALC, enter the TALC’s name or num-

ber as the file name.

5. Ensure that the Save as type drop-down box selection shows text file (*.txt).

6. Specify the folder where you want to save the file.

7. Click on theOK button. The file is saved.

Note: TelStrat strongly recommends that you do not manually edit TALC .txt configuration files. Instead, use

the procedures referenced in the this guide for making changes, viewing and storage.

Open an Existing Configuration File

To open an existing TALC configuration file:

1. Use the Administration PC Start menu to launch the Configuration Manager.

2. Log on to the TALC being worked on.

3. From theMenu bar, choose File → Open. TheOpen dialog box displays.

4. Ensure the Files of type drop-down box shows text files (*.txt).

5. Navigate to the folder containing the file to open.

6. Select the file and click on theOpen button. The contents of the configuration file are loaded into Con-

figuration Manager property sheets in the system tree.

7. View the configuration details by expanding the system tree and clicking each item in the system tree to

display the associated property sheet.

8. Make changes to the property sheet information, as necessary.

9. Save the file by choosing File → Save from theMenu bar. If changing the file name, choose File → Save

As from theMenu bar.
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10. Click on the Send button to update the TALC, then chooseUpload/Download→ Save to Flash from the

Menu bar.

Uploading a Configuration to a TALC

For complete instructions on uploading a configuration to a TALC, refer to the Restoring the Configuration pro-

cess section.

Downloading a Configuration from a TALC

For complete instructions on downloading a configuration from a TALC, refer to the Creating a Backup Con-

figuration File process section.

3.6 Logging On and Off of a TALC

If you want to update the Flash memory on the TALC as you make configuration changes or view statistics

and logs, you must log on to the TALC. Each TALC has its own administration ID and password in addition to

the Configuration Manager logon ID and password.

You can log on to a specific TALC by using either of the following connection methods:

l Serial connection (direct connect or modem)

l Telnet (over the IP network)

Connection Types

Serial

If the TALC is connected to the administration PC by an RS-232 cable, a user can establish a connection

through the serial port. Similarly, you can establish a modem connection if the TALC or an Avaya Remote Gate-

way 9150 unit is connected to a modem. Modem settings are typically: 9600bd, 8 bits, 1 Stop bit, N parity,

Com 1-4 only, NULL serial cable.

Telnet
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If Ethernet connectivity has been established between the administration PC and the TALC, a user can estab-

lish an IP connection using Telnet.

Default Logon ID and Password

The default logon ID is guest. Users cannot change the logon ID.

The default password is guest123. A user can change the password and, therefore, it maybe different if this is

not a first time installation. TelStrat recommends that you do not change the password until your Engage

Record system is up and running smoothly.

Connection History

Configuration Manager maintains a record of past TALC connections. A user can select and then connect to a

TALC from the history list that displays in the Connectmenu.

Note: Upgrading the Configuration Manager software deletes the connection history list.

Auto Logoff

If the connection remains open with no activity for 15minutes, then Configuration Manager automatically

logs off the connection and the Session Timed Outmessage displays. This helps to secure the configuration in

the event that the user walks away from the administration PC while logged on to a TALC.

TALC Logon Procedures

There are three ways to logon to a TALC unit:

l Logon using a Serial port connection.

l Logon using a Telnet connection.

l Logon using the Connection History List.

Log on to a TALC Using the Serial Port

To log on to a TALC using the serial port:
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Note: Use the serial port connection to perform the initial configuration of the TALC.

1. From theMenu bar, choose Connect » Logon Unit » Serial. The Serial Port Configuration dialog box dis-

plays:

2. In the Port Number field, enter the COM port number that the TALC is connected to, then click OK.

3. Enter your logon name and password, then click on theOK button. The connection attempt is ini-

tiated. Themessage Trying to Connect via Serial Port <port number>might appear.

Regarding the connection:

IF the logon
attempt... Then...

Fails The following messages may appear: SERIAL CONNECTION FAILED or

SERIAL CONNECTION NOT ESTABLISHED.
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IF the logon
attempt... Then...

Check the serial port connections and ensure they are well connected at

both ends.

Check themodem settings.

Go back and attempt the logon again.

Is Successful TheUser Logged In dialog box displays.

Click on theOK button. The Startup Information dialog box displays:
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IF the logon
attempt... Then...

Messages appear above the progress bar at the bottom of the dialog box:

l Reading Hardware Information

l Reading DSP Load Data

l Reading Configuration Data

Thesemessages mean that Configuration Manager is obtaining the TALC’s

information from Flash memory. When initialization is complete, the Con-

figuration Data Read Successfullymessage appears above the progress bar.

Click on the Close button.

Log on to a TALC Using Telnet

To log on to a TALC using Telnet:
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Note: If someone else has logged on to the TALC before you, you cannot log on. A user can only log on to a

TALC using a Telnet connection after performing the initial configuration through a serial connection.

1. From theMenu bar, choose Connect » Logon Unit » Telnet. The Telnet Configuration box displays. Enter

the IP address of the TALC to log on to (ex. 192 168 152 188). Click OK.

2. If no one else logged on to the TALC, theUser Authentication for Telnet Mode dialog box displays. Enter

the following:
a. Login Name field: Enter the logon user default logon name.

b. Password field: Enter the user default logon password.

3. Click on theOK button. The Configuration Manager initiates a connection attempt. A Connection Status

message boxmay appear noting the attempt to connect.
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Regarding the connection:

IF the logon
attempt... Then...

Fails The following message displays:

10060 TELNET CONNECTION FAILED

Click OK, go to the logon window, check the address and re-attempt the

logon.

Is Successful TheUser Logged In dialog box displays.

Click on theOK button. A Startup Information dialog box displays.
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IF the logon
attempt... Then...

Messages appear above the progress bar at the bottom of the dialog box,

similar to the following:

l Reading Hardware Information

l Reading DSP Load Data

l Reading Configuration Data

Thesemessages mean that Configuration Manager is obtaining the TALC’s

configuration information from Flash memory.

When initialization is complete, the Configuration Data Read Successfully

message appears above the progress bar.

Click on the Close button.

Log on to a TALC Using the Connection History

To log on to a TALC using the connection history:
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1. From theMenu bar, choose Connect » xxx.xxx.xxx.xxx (xxx.xxx.xxx.xxx being the IP address on the list of

the TALC to log on to).

2. If no one else logged on to the TALC, theUser Authentication for Telnet Mode dialog box displays. Enter

the following:
a. Login Name field: Enter the logon user default logon name.

b. Password field: Enter the user default logon password.

3. Click on theOK button. The Configuration Manager initiates a connection attempt. A Connection Status

message boxmay appear noting the attempt to connect.

Note: The connection speed may be too fast for this message to be seen in a successful logon

attempt.

4. If you do not enter any logon information, after two minutes Configuration Manager displays a Please Try

Again reminder dialog box. Click on OK to return to the Telnet logon box.
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Regarding the connection:

IF the logon
attempt... Then...

Fails A Connection Failedmessage box displays:

Click OK, go to the logon window, check the address from the list and re-

attempt the logon.

Is Successful TheUser Logged In dialog box displays.

Click on theOK button. The Startup Information dialog box displays.
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IF the logon
attempt... Then...

Messages appear above the progress bar at the bottom of the dialog box:

l Reading Hardware Information

l Reading DSP Load Data

l Reading Configuration Data

Thesemessages mean that Configuration Manager is obtaining the TALC’s

configuration information from Flash memory.

When initialization is complete, the Configuration Data Read Successfully

message appears above the progress bar.

Click on the Close button.

TALC Logoff Procedures

Log off of a TALC
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When the user is finished using Configuration Manager to make configuration changes, view logs or statistics,

log off from the TALC. Logging off secures the TALC’s configuration.

To log off of the TALC:

1. From theMenu bar, choose Connect » Logoff Unit. The LOG OFF dialog box displays.

2. Click on the Yes button. The TALC Configuration Manager: User Logged Off dialog box displays

3. Click on theOK button.

3.7 Performing a System Restart or Shutdown

The Configuration Manager provides controlled system restarts or shutdowns.

Note: Always perform a system restart each time the configuration is changed or the firmware is upgraded. A

shutdown can be performed to power-down the system for any reason.

Perform a System Restart

To perform a system restart:
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1. From theMenu bar, choose Connect » System Reset » Restart. The System Restart dialog box displays.

2. Click on the Yes button. A progress bar displays.

3. Themessage Restarting the System displays in the status bar at the bottom of the screen.

4. The status continues to showOnline. When the system restart is complete, a dialog box displays informing

the user that the system restart was successful, and that the user is logged off.

5. Click on theOK button.

6. Configuration Manager will prompt the user to log back on using the previous connection method (Serial

or Telnet).

Perform a System Shutdown

To perform a system shutdown:

1. From theMenu bar, choose Connect » System Reset »Shutdown. The System Shutdown dialog box dis-

plays.

2. Click on the Yes button. Configuration Manager disconnects the user's logon session and themessage

Shutting Down the System displays in the status bar at the bottom of the screen.

3. The status shows Offline.
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4. Turn the power on the TALC off.

3.8 Closing the Configuration Manager

When the user has completed all of the configuration modifications or is done viewing display logs and stat-

istics, log off and close the Configuration Manager application. This secures the configuration and prevents

others from accessing it if the user walks away from the administration PC while logged on to a TALC.

WARNING: There is a risk of configuration loss. If the user closes Configuration Manager without saving

the changes made to a file on administration PC or without updating the Flash memory of the TALC being

worked on, all changes are lost. The user will have to re-enter all changes again.

Close the Configuration Manager

1. Ensure all configuration changes have been saved by doing one or more of the following:
l From theMenu bar, choose File » Save As, and specify the name for the configuration file. Con-

figuration Manager saves the file on the administration PC hard disk.

l Update the Flash memory of the logged on TALC, by doing one of the following:
o Click on the Send button on any property sheet, then chooseUpload/Download » Save to

Flash from theMenu bar.

o ChooseUpload/Download » Save to Flash from theMenu bar.

o If the user has saved the changes to a file, chooseUpload/Download » Upload Con-

figuration » Save to Flash from theMenu bar.

2. Log off by choosing Connect » Logoff Unit from theMenu bar.

3. Choose File » Exit from theMenu bar.

4. Configuration Manager closes.
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4 PBX and TALC Configurations

Both the PBX system and the TALC system must be configured before call recording can take place.

4.1 PBX Configuration for Recording

The following telephone set programming needs to be confirmed prior to installation or upgrades of TALC

units.

All telephone sets on the PBX have a class of service assigned. All telephone sets that are to be recorded must

have these specific classes of service features assigned to them:

l TDD: Tandem Digit Display

l CNDA: Calling Party Name Display Allowed

OneDNDiscovery port must be programmed on port 16 of the TALC card with a class of service including:

l VCE: Voice

l FLXA: Flexible Voice/Data Allowed

l WTA: Warning Tone Allowed

l TDD: Tandem Digit Display

l CNDA: Calling Party Name Display Allowed

l Key 0 on the telephone is set to any unused DN as an SCR (single call ringing) key

Digital telephones sets in theMeridian 1 and CS1000 PBXs aremanaged using LD 11 in the user interface.

4.2 Configure a TALC Slot on a PBX

For the host PBX to communicate properly with the TALC, the PBX must recognize each TALC as an extended

digital line card (XDLC). This requires that each card slot occupied by a TALC be configured at the host PBX as

an XDLC slot.

Note: Configure a TALC’s slot either before or after inserting the card.
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To configure a TALC slot, access the host PBX through the host PBX administration terminal.

At the host PBX administration terminal, instruct the host PBX to recognize any slot that a TALC resides in as

an XDLC slot.

Refer to the host PBX’s documentation for the specific steps necessary to complete this procedure.

4.3 TALC System Configuration Property Sheet

Use the TALC System Configuration property sheet to set system-wide parameters on the TALC. Configure

these settings to determine:

l The identity of the TALC within the voice recording network.

l Whether the Engage Record server can record calls on this TALC.

l The location of the Engage Record server on the IP network.

l The times when the TALC automatically determines the directory number (DN) of the first line key asso-

ciated with each TALC port.

l The CCM telephone display format for the DNIS and CLID.

Each TALC unit will have its own set of property sheets to be configured. On the TALC System Configuration

property sheet, there are three areas of configurations and a row of command buttons to be used to control

the configuration effort. Configure the three sections of the property sheet as follows:

General Config Configuration

Unit ID: Enter a number from 1 through 254 that distinguishes the TALC being configured from all other TALCs

connected to the same Engage Record server. One Engage Record server can simultaneously record calls from

multiple TALCs spanning multiple host PBXs.

Node Name: Enter a descriptive name for this TALC (ex. Node 1).

Engage Record Feature: Click on the Enable option button to enable the Engage Record server to record tele-

phone calls made to ports on the TALC being configured. Only click on the Disable option button if the cus-
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tomer does not want to enable the Engage Record server to record telephone calls made to ports on the TALC

being configured.

Engage Record Server IP Address: Enter the IP address of the Engage Record server that records telephone

calls from this TALC.

Beep Tone Level: Use the slider bar to adjust the audio level (volume) of the beep tone relative to the voice

path. There are five audio levels, each step representing approximately 3db. The default is halfway between

minimum and maximum.

Note: The beep tone level can only be adjusted when Engage Feature is enabled using the TALC System Con-

figuration property sheet.

Per DN Recording: Confirm that the Per DN Recording check box is checked if the customer wants to record

multiple DNs connected to the same TN(phone). If the customer does not want to record multiple DNs con-

nected to the same TN, click on the Per DN Recording check box to disable this feature. The default is checked

(Enable).

DN Discovery Schedule Configuration

The DNDiscovery Schedule settings area of this property sheet contains fields for entering information that

the TALC needs to determine the directory numbers (DNs) configured on the host PBX for each of its ports.

When enabled, DNDiscovery periodically gathers this information for each feature key on the TALC without

the user having to enter it manually every time DN assignments change.

The opportunity to set these fields is provided during the Initial Configuration. They can be changed here, as

well.

To perform DNDiscovery, each TALC requires one single-appearance DN on a telephone connected to that

TALC. The TALC disables the ringer on the designated appearance but not on that telephone’s other appear-

ances. At the appointed time on the selected day or date, each feature key configured as a line key on the

digital telephone places a call to the TALC DN identified in the “TALC Extension to Dial” area of the TALC Con-

figuration Manager’s “TALC System Configuration property sheet,” as shown on page 56.
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For each call, the host PBX produces CLID information that identifies the DN of the originating feature key. Pla-

cing one call from every feature key on every TALC allows every TALC to send DN and associated DNIS inform-

ation to the Engage Record server for each call involving a telephone connected to that TALC. In this way, the

Engage Record server collects DN and associated DNIS information for every telephone on every TALC that

routes traffic through that server.

Note: DNDiscovery does not function on telephone sets that contain add-on modules. This causes Engage

Record call records to not contain DN and DNIS information.

PBX Class-of-Service

Enable the Tandem Digit Display (TDD) class-of-service on the host PBX to allow acquisition of DN and DNIS

information in all scenarios (such as, ACD environments, multiple DNs assigned to a single phone, and so on).

DN Discovery in ACD Environments

By default, DNDiscovery uses port 0 and feature key 0. This is not acceptable in an ACD environment that

uses feature key 0 as the in-calls key. DNDiscovery accepts another feature key with a single-appearance DN

assigned, but the user must also enable the TDD class-of-service on the host PBX. Configuring TDD class-of-ser-

vice allows caller ID information to be returned on all keys.

Configure DN Discovery Schedule box and field settings

l Enable DN Discovery: Is configured during Initial Configuration, however, it can be configured on this

sheet. Engage Featuremust be Disabled to allow the Enable DN Discovery check box to enable the TALC

being configured to automatically detect the host PBX-configured name and number assigned to every

line key on each TALC port, that is, to enable the TALC to perform DNDiscovery. Do not click in the Enable

DNDiscovery check box, or click again in the check box to clear it, if the customer does not want the TALC

to perform DNDiscovery.

Note: If you have enabled recording, DNDiscovery is required.
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l Frequency: Click on the option button that identifies how often the TALC is to perform DNdiscovery:
o Once a day,

o Once a week,

o Once a month.

l Start DN Discovery button: Click on the Start DN Discovery button to initiate an unscheduled DNDis-

covery.

Note: Start DNDiscovery is available (not grayed-out) only if the configuration in the TALC's Flash memory is

the same as the configuration at the local site, and if the Enable DNDiscovery check box is selected.

l Time: Choose the timewhen the TALC is to perform DNdiscovery.

l Day : Choose the day when the TALC is to perform DNdiscovery (if Once a week was selected in the Fre-

quency field).

l Date: Choose the date when the TALC is to perform DNdiscovery (if Once a month was selected in the Fre-

quency field).

l TALC Extension to Dial: These fields allow the user to specify one TALC port for DN discovery. At the con-

figured time, each port on the TALC places a call, one at a time, to the DN in the TALC extension to dial

field. For each call, the TALC assigns the incoming CLID name and number to the calling port.
o Port: Choose the TALC port that the user wants the other ports on this TALC to call for DNDis-

covery.

o Feature Key: Choose the Feature Key that corresponds with the port chosen for DNDiscovery in the

Port list box, usually 0.

l DN: Enter the directory number associated with the port chosen for DNDiscovery in the Port list box.
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Note: If the feature key is not key 0, such as in ACD environments, the user must configure the following

classes of service on the associated host PBX port: CLS = TDD. CLS is the prompt from the host PBX to define

the class of-service. Enter TDD to enable the Tandem Digit Display feature.

Note: Engage Record feature keys are not supported on DBAs.

Symposium Display Format Configuration

Contact Center Manager (CCM) is the current name for one of Avaya's contact centers. It is also known as

Symposium, thus, Symposium will be seen in the property sheet settings. It is the same as CCM.

If Engage is to record call records containing DNIS and ANI information in the Contact Center Manager (CCM),

then the user must configure CCM to display DNIS and ANI information on the telephone. This is required

because the Engage Record server obtains all call record information (ex. DNIS, ANI, Agent ID, etc) from the

TALC. The TALC only receives this type of information when it is sent to the TALC by the host PBX to be dis-

played on the telephone.

Note: The user must configure CCM to use the English language.

Configure the CCM (Symposium) to display DNIS and ANI information on the telephone:

1. Access the Contact Center Manager Server (CCMS) or CCM Express (CCME) using Avaya's CCMWeb

application.
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2. Click on ccmsc » Phoneset Displays in the left-hand pane to display all supported ACD telephones (ex.

M2216, M2616, M3904, and M3905.)

3. Double-click on the 1 x 24 and 1 x 18 Telephone Set Type to configure the telephone display.

Note: The 1 x 24 and 1 x 18 display contains two rows. However, Engage Record only requires con-

figuration of the first 2 fields of the first row. The first row can contain 24 characters and the second

row can contain 18 characters. The user can configure the CLID number (ANI) or DNIS on either row.
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4. Drag the item(s) chosen, such as the DNIS or CLID number (ANI), to the first row of the display, drop them

in the order that you choose, and drag the side of the item to the appropriate width, similar to the fol-

lowing figures:

5. Click on theOK button.

Symposium Display Format box and field settings

Configure the TALC to receive the DNIS and ANI by setting these fields:
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l DNIS Row: Enter the row number for displaying the DNIS on the telephone display. Valid options are 1 and

2where 1 is the top row and 2 is the bottom row. The default is 1.

l DNIS Offset: Enter the offset number (number of columns counting from left to right) for displaying the

DNIS on the telephone display. Valid options are 1 through 24 for the first row of the telephone display.

Valid options are 1 through 18 for the second row of the telephone display. The default is 1.

l DNIS Length: Enter the length of the DNIS to display on the telephone display. Valid options are 0 through

24 for the first row of the telephone display. Valid options are 0 through 18 for the second row of the tele-

phone display. The default is 10.

l CLID Row: Enter the row number for displaying the CLID on the telephone display. Valid options are 1 and

2where 1 is the top row and 2 is the bottom row. The default is 1.

l CLID Offset: Enter the offset number (number of columns counting from left to right) for displaying the

CLID on the telephone display. Valid options are 1 through 24 for the first row of the telephone display.

Valid options are 1 through 18 for the second row of the telephone display. The default is 11.

l CLID Length: Enter the length of the CLID to display on the telephone display. Valid options are 0 through

24 for the first row of the telephone display. Valid options are 0 through 18 for the second row of the tele-

phone display. The default is 10.

Note: Symposium Display Format section refers to the format of the CCM Display.
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4.4 TALC IP Configuration Property Sheet

Use the TALC IP Configuration property sheet to configure information that gives the user the ability to con-

figure a TALC over an IP connection.

This includes the TALC’s

l IP address,

l Subnet mask,

l Default gateway.

Management

In addition to the IP address, subnet mask, and default gateway, the TALC also allows users to assign a static

IP address and IP mask to themanagement port on the TALC. Once assigned this information, users can use

the host PBX administration PC to log on to and administer the TALC through the host PBXs internal network.

TALC IP Configuration Property Sheet fields
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l IP Address fields: Enter the address of the TALC.

l IP Network Mask fields: Enter the network mask of the TALC.

l IP Gateway fields: Enter the IP Gateway of the TALC.

l Management:
o Disable checkbox: Check theDisable checkbox if the user does not want to be able to complete the

host PBX administration from the TALC.

o Management IP address: Enter themanagement IP address of the host PBX.

o Management IP Mask: Enter themanagement IP mask of the host PBX.

Entering the IP Information

To enter the IP information into the TALC IP Configuration property sheet:

1. Enter the IP address, mask, and gateway of the TALC into the appropriate fields inthe first three rows of

the TALC IP Configuration property sheet.



ag160414 Copyright © 2016, TelStrat International, Ltd.
All rights reserved.

79

IF you want to... Then do this...

Use the host PBX’s man-

agement IP connection to com-

plete TALC administration.

1. Clear theDisable check box.

2. Enter the IP address and mask ofthe TALC’s second Eth-

ernet portnto the appropriate boxes in theManagement

section of the TALC IPConfiguration property sheet.

NOT use to your host PBX’s

management IP connection to

complete TALC administration

Click on theOK button and continue.

2. Click on the OK button.

3. Update the TALC with the new information clicking on the Send button.

IF you are... Then...

Logged on to the TALC The changes are written to a temporary file on the administration PC.

Note: To save changes to the TALC’s Flash memory, chooseUpload » Save to

Flash.

NOT logged on to the

TALC

A dialog box display:

Log on to the TALC, then on the click Send button again.

The revised IP information is written to the TALC’s Flash memory
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If the user changes the TALC IP Address field on the TALC IP Configuration property sheet, calls do not record

when the user initializes a recording through the Engage Record client.

This is do to the fact that the Engage Record server does not update the board list when the same board ID is

used with the new TALC IP address. The Engage Record server adds the board ID entry.

However, when the user initializes a recording, the Engage Record server references the previous TALC IP

address. Therefore, the Engage Record server never receives a Call End from the expected TALC IP address and

therefore does not save the call. The Engage Record client generates a warning message in its Message Center

pane and the system generates a log indicating that duplicate board IDs exist. To resolve this issue, restart the

TALC card after changing a TALC IP address.

4.5 TALC Port Configuration Property Sheet

Use the TALC Port Configuration property sheet to configure the following characteristics of the telephones

connected to ports on the TALC:

l Whether the Engage Record server can record calls through the ports.

l The feature keys that are to have Engage Record functionality.

l The compression rate that you want the port to use.

l Whether you want the port to react with a Telephone Application Programming Interface (TAPI) server.

l Whether you want the port to be connected to an M2250 Console telephone.

Note: The TALC sends CLID information (up to 18 characters) to the Engage Record server for calls handled on

theM2250 Console telephone Loop Pickup Keys (LPKs) and the Engage Record server determines if the call is

to be saved. The Engage Record server populates the ANI field in the Engage Record client with available

Caller ID information to and from theM2250 Console telephone set.



ag160414 Copyright © 2016, TelStrat International, Ltd.
All rights reserved.

81

l Whether you have fixed-seating ACD configured on your PBX

l Whether you want all parties on a telephone call to hear a beep tone to let them know that the telephone

call is being recorded.

l Whether you want telephone users, not attached to a TALC, to conference in to an unattended DN on the

TALC.

TALC Port Configuration Element Descriptions

l Enable button: Click on the Enable button if the user wants the Engage Record server to be able to record

conversations on the associated port.

l Disable button : Click on the Disable button if the user does not want the Engage Record server to be able

to record conversations on the associated port.

l Configure button : Click on the Configure button if the user wants to configure the Engage Record feature

keys, the compression rate, TAPI support, and M2250 support for the associated port.

Engage Record Feature Keys

Part of the TALC configuration allows assigning of Engage Record feature keys. These softkeys will appear on

assigned keys on the digital telephone set. The keys are described as:
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l Record key: When clicked, commences recording the call.

l Conversation Save key: When click,ed saves this call recording.

l Delete Recording key: When clicked, deletes the entire recording from start to finish.

Fixed Seating

If the user's ACD agents can log on to their telephone sets using their Make Set Busy keys, the PBX is con-

figured for fixed seating.

For Engage Record call records to contain ACD Agent ID information in this mode of operation, the user must:

1. Access the TALC Port Configuration property sheet.

2. Click on the Configure button.
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3. Click on the Configure Agent ID check box.

4. Enter the ACD agent’s Agent ID in the Enter Agent ID field.

Note: This also allows the user to create recording criteria using the ACD Agent ID.

Free Seating

If the user's ACD agents must log on to their telephone sets by entering their Agent ID, the PBX is configured

for free seating.

The user's Engage Record system’s call records can contain ANI and DNIS information. To do this, the user

must:



ag160414 Copyright © 2016, TelStrat International, Ltd.
All rights reserved.

84

1. Configure CCM to provide DNIS information in the first field of the first line of the telephone display.

2. Configure CCM to provide ANI information in the second field of the first line.

Note: This allows users to create recording criteria using DNIS and ANI information.

Fixed seating or free seating is a PBX configuration

If agents must log in with an Agent ID, they work in a free seating environment. This is true even if they use

the same telephone set every shift or if they sit in the same seat every shift.

Configuring a TALC Port

To configure a TALC port:

1. Click on the appropriate tab for the port being configured, as in 0-15 for a single wide TALC, 0-15 or 32-47

for a double-wide TALC.

2. Click on the appropriate option button associated with the port you are configuring according to whether

the user wants to Enable or Disable recording.

Note: Enable is the default setting. If the user does want to enable recording on a specific port, then

select Disable.

3. Click on the Configure button associated with the port being configured to set the Engage-related feature

keys (Conversation Save, Record, Delete Recording) and compression rate for any telephone connected to

that port. The TALC Feature Key Configuration dialog box displays:
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4. Configure the settings in the TALC Port Configuration options dialog box.

5. Click on the Send button to update the TALC with the new information.

IF you are... Then...

Logged on to the TALC The changes are written to a temporary file on the administration PC.

Note: To save changes to the TALC’s Flash memory, chooseUpload » Save to

Flash.

NOT logged on to the

TALC

A dialog box display:
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IF you are... Then...

Log on to the TALC, then on the click Send button again.

The revised IP information is written to the TALC’s Flash memory

TALC Key Feature Configuration Dialog Box Field Descriptions

Field Description

Key

Feature

Select the Key Feature that you want to assign.

Valid options are Conversation Save Key, Record Key, Delete Recording Key and Not Con-

figured.

Key Num-

ber

Select the feature key that you want to assign the Key Feature chosen in the list box to the

left. The feature key must be not configured on the host PBX.

Valid options are NC (not configured) and 0 through 75, depending on theMeridian digital

telephonemodel.

Com-

pression

Rate

Choose the compression rate that you want to be applied to recordings made through the

associated port.

Valid options are G.711 and G.723.1 (6.4K).

The default is G.723.1.

TAPI Sup-

port

When you enable Telephone Application Programming Interface (TAPI) support, telephones

using the selected port can react to a TAPI server message stimuli such as Meridian Com-

municator.
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Field Description

l Click on the Enable option button if you want this port to react to a TAPI server.

l Click on the Disable option button if you want to prevent this port from reacting to a

TAPI server.

The default is Disable.

When configured for TAPI support, the TALC allocates DSP and bandwidth resources

whenever a line key indicator goes active and stays active for Multiple Appearance DNs. To

prevent the over-allocation of these resources during midnight routines, either disable LD

35, or configure the TALC as Offline during this period.

Note: You must configure CS 2100 ATA sets and CS 2100 AAB sets for TAPI support for them

to function properly.

2250 Sup-

port

When 2250 support is enabled, the selected port can interact properly with an M2250 con-

sole telephone.

l Click on the Enable option button if the user wants this port to interact properly with an

M2250 console telephone.

l Click on the Disable option button if the user wants to prevent this port from interacting

properly with an M2250 console telephone.

The default is Disable.

2250 Sup-

port:

2250 Sec-

ondary

Port No.

If 2250 support is enabled, select theM2250's secondary port from the drop down list.

Valid options are NC (Not Configured) and 0 through 63.

The default is NC.

Agent ID: Click on the Configure Agent ID check box if you have fixed seating ACD configured on your
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Field Description

Configure

Agent ID

host PBX.

Note: Do not configure Agent IDs in free seating environments.

Enter

Agent ID

If you click on the Configure Agent ID check box, you must enter the Agent ID in this field.

This must be the same number configured as the User ID on the Engage system and as Pos-

ition ID on the host PBX.

Beep

Tone

When the user enables the Beep Tone feature, all parties on a telephone call hear a beep

tone to let them know that the telephone call is being recorded. The beep tone is on for 425

milliseconds (ms), +/-75ms, and then off for the remainder of 15 seconds, repeating this

cycle until the call is terminated.

l Click on the Enable option button if the user wants to enable the beep tone.

l Click on the Disable option button if the user does not want to enable the beep tone.

The default is Disable.

Note: If the telephone user presses the Delete Recording feature key, the beep tone is

removed and no longer heard by all parties on the call. The Conversation Save and Record

feature keys become inactive while the Delete Recording key feature is active. If the tele-

phone user presses the Delete Recording feature key a second time to deactivate the fea-

ture, the beep tone is added back and all parties on the telephone call hear the beep tone

again. This allows the telephone user to delete a portion of the conversation that did not

have the beep tone supplied to all parties.

Virtual

Phone

Record-

ing

When the user enables the Virtual Phone Recording feature, all telephone users that are not

attached to a TALC, conference to an unattended DN on the TALC. The unattended DNs are

mapped to feature key 0 on an M3904 digital telephone set programmed on the PBX. The

TALC assumes this PBX configuration on the port and acts as if theM3904 digital telephone

set is actually attached to the TALC. This allows telephone calls presented to theM3904
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Field Description

digital telephone sets to be recorded through the Engage system. The TALC auto-answers all

telephone calls presented to these unattended M3904 digital telephone sets.

l Click on the Enable option button if the user wants to enable virtual phone recording.

l Click on the Disable option button if the user does not want to enable virtual phone

recording.

The default is Disable.

Note: Virtual Phone recording ports do not offer disconnect supervision prompting calls to

disconnect after a certain amount of time. If an outside un-supervised trunk call dis-

connected to the Virtual Phone recording port, then that call remains active until the Cen-

tral Office (CO) tells the host PBX that the call has been terminated
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5 Password Administration

Password Administration of the Configuration Manager and all TALC units is required.

Changing the Administration Passwords

Two layers of password security protect the TALC's configuration. If the user wants to secure the TALC's con-

figuration so that only those with passwords unique to the TALC can make configuration changes, alter the fol-

lowing items:

Configuration Manager password: This password prevents unauthorized users from performing offline con-

figuration changes.

TALC password: This password prevents unauthorized users from performing online changes of the con-

figuration in the TALC's Flash memory.

Note: Ensure that the user records the password and stores it in a safe and secure place. If the passwords are

forgotten or lost, the user must re-enter all configuration information. Contact TelStrat Customer Services

for assistance.

Changing the Configuration Manager Password

Default Configuration Manager user name and password are: admin and root.

To change the Configuration Manager (local) password:

1. Choose Connect » Change Password » Local from theMenu bar. The Change Password - Local dialog

box displays:
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2. Completed the fields in the Password Dialog Box.

The Password Dialog box descriptions are:

l Old Password: Enter the existing password.

l New Password: Enter the new password.

l Retype New Password: Enter the new password again.

3. If the password change failed, a dialog box appears indicating what is needed (ex. Incorrect Old Password).

4. If the password change succeeded, a dialog box appears. Click OK.

Changing the TALC Password

Default TALC user name and password are: guest and guest123.

To change the TALC's (node) password:
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1. Choose Connect » Change Password » Node from theMenu bar. The Change Password - Node dialog

box displays:

2. Completed the fields in the Password Dialog Box.

The Password Dialog box descriptions are:

l Old Password: Enter the existing password.

l New Password: Enter the new password.

l Retype New Password: Enter the new password again.

3. If the password change failed, a dialog box appears indicating what is needed (ex. Incorrect Old Password).

4. If the password change succeeded, a dialog box appears.
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5. This means the password has been written to the TALC’s Flash memory. Click OK
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6 Create a Backup Configuration File

Create a backup copy of the TALC’s configuration by downloading the TALC’s configuration from Flash

memory to a text file on the administration PC.

TelStrat recommends that the user create a backup of the configuration file(s) whenever configuration

changes aremade or after a firmware upgrade.

Storing Backup Configuration Files

The TALC is an extension of the telecommunications and data network. It is extremely important that the user

keep a backup copy of the TALC’s configuration. If the TALC’s Flash memory or configuration becomes cor-

rupted or is lost, the user can easily restore it.

Store the configuration file in a safe, secure location, such as on backup tape or other media that is stored off

site. TelStrat recommends that the user keep the backup files indefinitely.

Creating the Backup File

To create the backup file:

1. ChooseUpload/Download » Download Configuration from theMenu bar. TheDownload Con-

figuration dialog box displays:
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2. Choose themode to use for the file transfer according to the following table:

IF saving the con-
figuration to... Then do this...

the administration PC Click on theDump option button.

a different location on the IP net-

work

1. Click on the TFTP option button. This enables the IP

Address fields.

2. Enter the IP address of the PC that you want to save the

configuration file on.

3. Click on the Browse button and navigate to the folder used to keep the configuration text file.

4. Enter a name for the file in the File Name field.

Note: This configuration file becomes the backup file, so ensure the file name is meaningful. The file

name’s extension must be .TXT.

5. Select the configuration file, and click on theOpen button. The chosen file displays in the File Name field.

6. Click on theDownload button. The following message displays in the Log Reportwindow:

Downloading Configuration from board. Please wait....

7. When the download is complete, the following message displays in the Log Reportwindow:

Configuration Data download complete

8. Click on the Close button.
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7 Restoring a Configuration File

Restore the configuration to the TALC’s Flash memory by uploading a configuration textfile from a PC on the

same network as the TALC. To do this, perform the upload over theIP network using the TFTP protocol.

Use a TFTP server application, such as PumpKIN, running on the administration PC. The TFTP server’s base dir-

ectory must point to the directory that contains the configuration file needed to upload for restoration.

Before You Begin

Complete the following steps:

1. Start the TFTP server application (e.g. PumpKIN).

2. Ensure that the TFTP base directory points to the location of the configuration file.

Uploading a Configuration File Over the IP Network

To upload a configuration file over the IP network:

1. ChooseUpload/Download → Upload Configuration from theMenu bar. TheUpload Configuration dia-

log box displays:

2. Enter the IP address of the TFTP server in the IP Address fields.
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Note: Since the TFTP server application is running on your administration PC, this is the IP address of

the administration PC.

3. Click on theOpen button. TheOpen dialog box displays:

4. Ensure the Files of type drop-down box shows Text File (*.TXT) and navigate to the folder containing the

configuration file.

5. Select the configuration file, and click on theOpen button. TheUpload Configuration dialog box displays

with the file you selected in the File Name field.

6. Click on theUpload button. If the file opens successfully, then the upload proceeds. The following mes-

sage displays in the status bar at the bottom of the screen:

Uploading Config to Board

7. The Log Reportwindowdisplays status messages relating to the upload:
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WARNING: Risk of incorrect operation due to partial configuration. Do not interrupt the configuration

upload. If the configuration upload is interrupted, the result is an incomplete configuration in the

TALC's database. If the configuration upload is interrupted, repeat this procedure immediately.

IF the upload
was... Then...

Successful The following message displays:

CONFIG UPLOAD SUCCESSFUL... USE SAVECFG TO UPDATE FLASH.

Proceed to step 9.

NOT Successful The following message displays in themiddle of the Upload Con-

figuration dialog box:

CONFIG UPLOAD FAILED

For further instructions, refer to the Troubleshooting section of this

guide.
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8. On theUpload Configuration dialog box, click on the Save to Flash button. The FLASH CONFIG dialog box

displays:

9. Click on the Yes button. The following message displays in the status bar at the bottom of the screen:

Saving to Flash in Progress

10. When the save is complete, the following message displays in themiddle of theUpload Configuration dia-

log box:

CONFIGURATION IS UPDATED INTO FLASH...

11. Click on Close.

12. Restart the TALC.
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8 Managing Display Logs

The TALC system keeps track of its performance through statistical logs that technical support personnel can

use to locate and fix problems. Each line, or display log, represents a separate action completed by the TALC.

Configuration Manager gives you several ways of working with these logs to provide the information technical

support needs to keep your voice recording system operating at its peak.

Logs are technical support tools. If you request technical support, you may be asked to provide a copy of the

logs.

Access these logs through the Alarms/Stats/Logsmenu.

To view the definitions of the logs provided by the Engage system, chooseHelp → Help Topics → Display

Logs →Display Log Definitions from theMenu bar.

Viewing Display Logs

To view the display logs:

1. Choose Alarms/Stats/Logs → Display Logs from theMenu bar. TheDisplay Logs dialog box displays:

2. Use the scroll bar to browse through the logs to find the information that you ar interested in.

3. When you finish viewing the log, click on the Close button.

Saving the Log to a File
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If you request technical support, the technician often asks for a copy of the logs. To save the log to a file on

your administration PC, follow this procedure:

1. Select the text you want to copy and then press Ctrl-C.

2. Open WordPad or Notepad.

3. Press Ctrl-V to paste the text.

4. Save and close the text file.

Resizing the Number of Logs to Display

Use the Resize Logs command to increase (to as many as 1000) or decrease (to as fewas one) the number of

display logs stored in the TALC’s log queue. When the number of display logs in the queue reaches the num-

ber of lines configured in this field, new display logs overwrite existing display logs on a first in, first out basis.

Note: Because logs are located on the TALC, they do not occupy disk space on the administration PC.

To change the number of theDisplay Logs in the queue:

1. Choose Alarms/Stats/Logs → Resize Logs from theMenu bar. Configuration Manager displays the cur-

rent size of the log queue and gives you the option of changing the size of the queue.
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Note: The queue size, in this case, is the number of display logs in the queue. The default capacity of

the queue is 1000 display logs.

2. Enter themaximum number of logs you want the TALC to keep in the queue at any one time.

3. Click on theOK button.

Clearing Logs

Use the Clear Logs command to discard logs that are no longer useful.

To clear the display logs:

Choose Alarms/Stats/Logs → Clear Logs from theMenu bar. The CLEAR LOGS dialog box displays:

IF you select... Then...

No The CLEAR LOGS dialog box closes and the logs remain as they are.

Yes The TALC deletes its stored display logs.

The LOGS Cleared dialog box displays:
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IF you select... Then...

Click on theOK button.
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9 DSP and VCT Statistics Screens

All statistics screens provided by the Alarms/Stats/Logsmenu, function primarily to helpyou obtain inform-

ation to provide to technical support personnel, upon request.

Digital Signal Processor (DSP) Statistics Screen

Digital Signal Processor (DSP) Statistics provide information about the TelStrat DSP 8modules installed on the

logged-on TALC. Use this screen to determine themodule positions that are populated, what type of DSP

each populated position contains, and the functionality provided by each module. The DSP Statistics screen is

similar to the following:

Displaying DSP Statistics

Choose Alarms/Stats/Logs → DSP Statistics from theMenu bar to display the DSP Statistics screen. Con-

figuration Manager gathers statistics from the TALC and displays the DSP Statistics screen.

IT you want to... Then click...

Update the statistics with the latest information, the Refresh button.

Close the DSP Statistics screen, the Close button.

Obtain descriptions of the statistics in the DSP Statistics screen, theHelp button.

DSP Statistics Field Descriptions
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DSP Statistics fields are described as:

l Single Digit Service ID: Identifies internal sequence number for indexing DSP devices.

l Module Number: Identifies themodule position of the DSP. Valid values are 0, 1, 2, 3, and 4.

l Device Number: Identifies the DSP device that processed the call.

l In Service: Identifies the number of voice channels operating on this DSPdevice.

l Total MIPS: Identifies the total number ofMIPS on the DSP device.

l Available MIPS: Identifies theMIPS currently available on the DSP device.

l Total Channels: Identifies the DSP device's channel capacity.

l Total Voice Channels: Identifies the total number of voice channels on the DSP device.

l Available Voice Channels: Identifies the number of voice channels currently available on the DSP device.

l Total Modem Channels: Identifies the total number of channels on the DSP device that can transmit

modem calls.

l Available Modem Channels: Identifies the number of channels on the DSP device currently available to

transmit modem calls.

l Total Flex Channels: Identifies the total number of channels on the DSP device that can providemultiple

functionalities.

l Total Tones Channels: Identifies the total number of channels on the DSP device that can transmit tones.

l Total Reserved Channels: Identifies the total number of special purpose channels on the DSP device

reserved for internal use.

l Name: Identifies the name of DSP load running on this DSP device.

Voice Connection Table (VCT) Statistics Screen

Voice Connection Table (VCT) Statistics provide information concerning certain properties of the voice con-

nections that are active at the time that you request the statistics. Technical support personnel use these stat-

istics for troubleshooting purposes.
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Displaying VCT Statistics

Choose Alarms/Stats/Logs » VCT from theMenu bar to display the VCT Statistics screen. Configuration Man-

ager gathers statistics from the RLC and displays the VCT Statistics screen.

IF you want to... Then click...

update the statistics with the latest information, the Refresh button.

close the VCT Statistics screen, the Close button.

obtain descriptions of the statistics in the VCT Statistics screen, heHelp button

VCT Statistics Field Descriptions

The fields of the VCT Statistics screen are described as:

Connection ID: Identifies the serial number of this call through the lifetime of the logged on TALC.

TALC Port No: Identifies the port the call was processed through at the host site.

Start Time: Identifies the time and date when the call started.

Duration: Identifies how long the call lasted.
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10 Verify Firmware and Software Versions

This section describes how to determine the version of firmware and software currently installed TALC. Firm-

waremanagement includes:

l Verifying the Configuration Manager software version.

l Verifying the TALC software version.

l Determine the Current Versions of both software elements.

l Performing Firmware upgrades.

Verify the Configuration Manager Software Version

Before performing a firmware or software upgrade, determine what version is currently installed. This ensures

that the user does not replace the installed firmware or software with an older version.

To verify your TALC Configuration Manager software version:

1. ChooseHelp → About Configuration Manager from theMenu bar. The About TALC Configuration Man-

ager dialog box displays:

2. Review the About Configuration Manager dialog box. This identifies the version of TALC Configuration

Manager software installed in the system
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3. Click on theOK button.

Verify the TALC Software Version

1. Choose System Information → System Data from theMenu bar. The System Configuration Details dia-

log box displays:

2. Review the Unit Version box. This identifies the version of firmware installed on the TALC.

3. Click on the Close button.

Determine the Current Firmware and Software Versions

To determine what the current firmware and software versions are, refer to the Engage Product Release

Notes, found at the HTTP://ESUPPORT.TELSTRAT.COM portal.

http://support.telstrat.com/
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10 Perform TALC Firmware Updates

This section describes how to perform a firmware upgrade on a TALC.

The upgrade is accomplished over the IP network using the TFTP protocol. A TFTP server application must be

running on the administration PC. Ensure that the TFTP server’s base directory points to the directory that

contains the upgrade files.

When to Perform a Firmware Upgrade

Perform a firmware upgrade when it is determined that the TALC is using out-of-datefirmware.

About Firmware Upgrades and Configuration Files

Each time a firmware upgrade is performed, the configuration database is also converted (if necessary) to a

format that is compatible with the new firmware. Configuration settings are not affected by the conversion.

TelStrat recommends that each time a user performs a firmware upgrade, the first step should be to create a

backup copy of the converted configuration file, and store it in a safe secure location.

Obtain the Software, First

It is important to complete the following steps before performing a firmware upgrade:

1. Contact TelStrat or the TelStrat distributor to obtain the firmware upgrade.

2. Extract the upgrade files from the file received from TelStrat.

3. Start the TFTP server application.

4. Ensure the TFTP base directory reflects the directory where the firmware upgrade file to use resides.

Upgrading TALC Firmware

To steps to upgrade the TALC firmware are:

1. ChooseUpload/Download » Upload S/W from theMenu bar. Result: The Software Upload dialog box

displays:
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2. Enter the IP address of the TFTP server in the IP Address fields.

3. Note: Since the TFTP server application is running on your administration PC, this is the IP address of the

PC.

4. Click on the Browse button. TheOpen dialog box displays:

5. Ensure that the Files of type drop down box shows Upgrade Files (*.UPG).

6. Navigate to the folder where the firmware file is located.

7. Select the file (ex. talc-100.upg) and then click on Open. The Software Upload dialog box reappears.

8. The file you selected appear sin theUploaded File field.

9. Click on theUpload button
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10. Wait until the file uploads completely before entering any other commands. The Log Reportwindowdis-

plays a confirmation message when the upgrade completes.

11. Restart the TALC.

.
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10 Perform Configuration Manager Software Upgrades

Perform a software upgrade if it is determined that system is using out-of-date software.

Upgrading Configuration Manager Software

The steps to upgrade Configuration Manager software are:

1. Navigate to the directory that contains the upgrade files extracted earlier.

2. Double-click on the setup.exe file.

3. Follow the prompts on screen.

4. The InstallShield installs the software, overwriting the previous version.

5. Close the installer, when complete.
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11 TALC Multi-I/O Cable-Enhanced Descriptions

TALC Multi-I/O Cable-Enhanced Description

The TALC Multi-I/O Cable–Enhanced (800-00072-03) is a 6-plug cable that provides the following connectivity:

The connector at is a providing connectivity to

P1 25 PR the switch's I/O panel

P2 DB-15 an external (user) Ethernet port

P3 DB-9 a serial port

P4 DB-15 the switch's internal Ethernet port

P5 reserved

TALC Multi-I/O Cable-Enhanced Pin-out Descriptions

How to read the tables

The this example, the first line of the table below is read as follows:

In pair 1 of bundleW1, the red wire connects pin P1-21 to pin P2-5 and carries this signal: EN0RXD+.

In Pair of bundle the wire connects pin to pin and carries this signal

1 W1 B-

L-

K

P1-21 P2-5 EN0RXD+

1 W1 R-

E-

D

P1-46 P2-

12

EN0RXD

Pin-out Information
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In Pair of bundle the wire connects pin to pin and carries this signal

1 W1 B-

L-

K

P1-21 P2-5 EN0RXD+

1 w1 R-

E-

D

P1-46 P2-12 EN0RXD-

2 W1 BLK P1-22 P2-6 EN0TXD+

2 W1 WHT P1-47 P2-13 EN0TXD-

P2-4 GND (SHD)

1 W2 B-

L-

K

P1-17 P3-3 SDIRXD

1 W2 R-

E-

D

P1-42 P3-2 SDIRXT

2 W2 BLK P1-45 P3-5 GND

2 W2 WHT

P3-1 P3-4 SDIDTR-SDIDCD

P3-4 P3-6 SDIDTR-SDIDSR

P3-7 P3-8 SDIRTS-SDICTS

1 W3 B-

L-

K

P1-23 P4-5 EN1RXD+

1 W3 R- P1-48 P4-12 EN1RXD-
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In Pair of bundle the wire connects pin to pin and carries this signal

E-

D

2 W3 BLK P1-24 P4-6 EN1TXD+

2 W3 WHT P1-49 P4-13 EN1TXD-

1 W4 B-

L-

K

P1-1 P5-1 (RESERVED)

1 W4 R-

E-

D

P1-26 P5-26 (RESERVED)

2 W4 BLK P1-2 P5-2 (RESERVED)

2 W4 WHT P1-27 P5-27 (RESERVED)

3 W4 BLK P1-3 P5-3 (RESERVED)

3 W4 GRN P1-28 P5-28 (RESERVED)

4 W4 BLK P1-4 P5-4 (RESERVED)

4 W4 BLU P1-29 P5-29 (RESERVED)

5 W4 BLK P1-5 P5-5 (RESERVED)

5 W4 YEL P1-30 P5-30 (RESERVED)

6 W4 BLK P1-6 P5-6 (RESERVED)

6 W4 BRN P1-31 P5-31 (RESERVED)

7 W4 BLK P1-7 P5-7 (RESERVED)

7 W4 ORG P1-32 P5-32 (RESERVED)
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In Pair of bundle the wire connects pin to pin and carries this signal

8 W4 RED P1-8 P5-8 (RESERVED)

8 W4 WHT P1-33 P5-33 (RESERVED)

9 W4 RED P1-9 P5-9 (RESERVED)

9 W4 GRN P1-34 P5-34 (RESERVED)

10 W4 RED P1-10 P5-10 (RESERVED)

10 W4 BLU P1-35 P5-35 (RESERVED)

11 W4 RED P1-11 P5-11 (RESERVED)

11 W4 YEL P1-36 P5-36 (RESERVED)

12 W4 RED P1-12 P5-12 (RESERVED)

12 W4 B-

R-

N

P1-37 P5-37 (RESERVED)

13 W4 R-

E-

D

P1-13 P5-13 (RESERVED)

13 W4 O-

R-

G

P1-38 P5-38 (RESERVED)

14 W4 G-

R-

N

P1-14 P5-14 (RESERVED)

14 W4 W-

H-

T

P1-39 P5-39 (RESERVED)
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In Pair of bundle the wire connects pin to pin and carries this signal

15 W4 G-

R-

N

P1-15 P5-15 (RESERVED)

15 W4 B-

L-

U

P1-40 P5-40 (RESERVED)

16 W4 G-

R-

N

P1-16 P5-16 (RESERVED)

16 W4 Y-

E-

L

P1-41 P5-41 (RESERVED)

1 W5 B-

L-

K

P5-9 P6-2 (RESERVED)

1 W5 R-

E-

D

P5-34 P6-14 (RESERVED)

2 W5 B-

L-

K

P5-10 P6-3 (RESERVED)

2 W5 W-

H-

T

P5-35 P6-16 (RESERVED)

3 W5 B-

L-

P5-11 P6-4 (RESERVED)
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In Pair of bundle the wire connects pin to pin and carries this signal

K

3 W5 G-

R-

N

P5-36 P6-5 (RESERVED)

4 W5 B-

L-

K

P5-12 P6-20 (RESERVED)

4 W5 B-

L-

U

P5-37 P6-6 (RESERVED)

5 W5 B-

L-

K

P5-13 P6-8 (RESERVED)

5 W5 Y-

E-

L

P5-38 P6-7 (RESERVED)

6 W5 B-

L-

K

P5-14 P6-17 (RESERVED)

6 W5 B-

R-

N

P5-39 P6-9 (RESERVED)

7 W5 B-

L-

K

P5-15 P6-24 (RESERVED)

7 W5 O- PR-40 P6-11 (RESERVED)
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In Pair of bundle the wire connects pin to pin and carries this signal

R-

G

8 W5 R-

E-

D

P5-16 P6-15 (RESERVED)

8 W5 WHT P5-41 P6-12 (RESERVED)

Delete this text and replace it with your own content.



ag160414 Copyright © 2016, TelStrat International, Ltd.
All rights reserved.

120

12 Troubleshooting

The questions listed in this section can help you determine the proper course of action for addressing the

problem.

Identifying Why a Problem Occurred

Before beginning any troubleshooting , answer these questions:

Question Answer The do this...

Is this a new installation? Yes Perform the troubleshooting in the sequence

presented in this section.

No Go to the next question.

Did the TALC work, then suddenly

stop working?

Yes Go to the next question.

No Perform troubleshooting in the sequence presen-

ted in this section.

Did the configuration get modified or

change any hardware components?

Yes Verify that changes weremade correctly.

Check the hardware components and con-

nections to ensure they are working correctly.

Perform troubleshooting for the specific com-

ponent where the problem occurred.

No Contact the local telecom or data network admin-

istrator. Theremay be a problem with the net-

work.

12.1 Using TALC LEDs
TelStrat Application Line Card LEDs
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The primary purpose of TALC LEDs is to give a visual indication of the line card’s general health. When reset-

ting the TALC, watch the faceplate. The LEDs should behave as follows:

l TheMaintenance LED should flash three times, then go off after the switch enables the TALC. (In normal

operation of the TALC, theMaintenance LED should remain off.)

l The remaining LEDs flash whenever there is network activity.

What to do if the LEDs do not Display Correctly

The following table describes what to do if the LEDs do not display correctly:

Symptom What to do...

TheMaintenance LED

did not flash three

times during the

power-up cycle.

1. Reset the TALC. Watch theMaintenance LED again. About 60 seconds pass

before it flashes.

2. If theMaintenance LED still does not flash, contact the distributor. There

may be a hardware problem.
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Symptom What to do...

TheMaintenance LED

remains lit after a suc-

cessful self-test.

1. Confirm that the slot is enabled on the host PBX.

2. If other LEDs are not lit or flashing, did theMaintenance LED ever light? If

not, contact the distributor. Theremay be a hardware problem.

3. Ensure that the TALC is properly seated in its slot and is properly inserted

into the backplane.

4. If the TALC is improperly or incompletely seated, reseat it.

5. If theMaintenance LED remains lit, contact the distributor. Theremay be a

hardware problem.

TheMaintenance LED

is flashing.

The power-up self-test failed. Contact the distributor. Theremay be a hard-

ware problem.

No LEDs are lit on the

TALC.

Ensure that the TALC is properly seated in its slot. If the TALC is properly

seated in its slot and no LEDs light, contact the distributor. Theremay be a

hardware problem.

The Ethernet COLL LED

is lit solid.

Network collisions are bound to occur and are normal. However, if this LED is

lit solid, do the following:

l Check the physical network connection.

l Verify the TALC can receive and send a PING.

l Check the network configuration (such as routing, traffic load, and so on).

Adjust the network configuration, if required.

l There should be no broadcast or multicast activity on the telephony LAN

(TLAN). Interconnect a hub and a network analyzer to the TLAN and mon-

itor for such activity. Identify the source(s) and isolate them from the TLAN.
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12.2 Checking Network Connectivity

This section describes problems that can occur on the network and steps you can take to resolve those prob-

lems.

Telephone Set Indicator

When the TALC card loses connection to the Engage server, the phone can or may display themessage CP

Server Down on the display of the phone. This message is generated by the TALC card for the phones that are

connected on it

Symptom Descriptions

If unable to establish TALC connectivity on the network, follow these steps to identify and repair the con-

nection:

Symptom What to do...

Cannot establish a con-

nection from the admin-

istration PC to the TALC.

1. Ensure that the entered the IP address is correct when trying to estab-

lish the connection.

2. Ensure that the entered the logon ID and password is correct when

trying to establish the connection.

3. Ensure that the TALC’s IP address, network mask, and default gate-

way are correctly configured in the TALC.

4. Ping the TALC.

5. Ping the gateway.

6. If the ping still does not work, contact the local data network admin-

istrator.

10060 TELNET CONNECTION
FAILED displays when

attempting to connect to

the TALC.

1. Ensure that the entered the logon ID and password are correct when

trying to establish the connection.

2. Ensure that the entered the IP address is correct when trying to estab-

lish the connection.
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Symptom What to do...

3. Ensure that someone is not already logged on to the TALC.

4. Verify that the Ethernet cable is connected at both ends (TALC and net-

work hub).

5. Check the Ethernet cable and ensure that it is good.

6. Ensure that the TALC is properly seated in its slot.

7. Verify that the IP address, subnet mask and gateway are all correct on

the TALC.

8. Ping the TALC.

9. If the TALC does not respond, ping the TALC’s gateway to see if it

responds.

10. If the gateway does not respond, ping a known good device on the

TALC’s network.

11. If steps 9 and 10work, but step 8 did not, theremay be a gateway con-

figuration error. Check the TALC’s IP Configuration property sheet.

12. Contact the distributor. Theremay be a hardware problem.

SERIAL CONNECTION FAILED
displays when attempting to

connect to the TALC.

1. Ensure that the entered the logon ID and password are correct when

trying to establish the connection.

2. Ensure that someone is not already logged on to the TALC.

3. Ensure the TALC is properly seated in its slot.

4. Re-seat the TALC.

5. Ensure that the specified COM port is correct when attempting the

connection.

6. Verify that no other applications on the administration PC are using

the COM port.
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Symptom What to do...

7. Ensure that the serial cable connection is good.

8. Use a breakout box to verify that the COM port is active.

9. Contact your distributor. Theremight be a hardware problem.

The TALC does not send or

receive Ethernet traffic.

1. Ensure that the TALC is seated in its slot properly and connected to

the backplane.

2. Ensure that the Ethernet cable between the TALC and the network is

good.

3. Ensure that the Ethernet cable is connected.

4. If the TALC still does not send or receive traffic, contact the local data

network administrator.

5. Data network administrator: Ensure other network devices are con-

figure to allow traffic to and from the TALC.

An attempt to log off from

the TALC does not work.

It is possible that communication has been lost between the admin-

istration PC and the TALC.

Close and restart Configuration Manager.

There aremany collisions on

the Ethernet network, as

indicated by the solid Eth-

ernet COLL LED.

Network collisions are normal. However, if this LED is lit solid, do the fol-

lowing:

1. Check the physical network connection.

2. Verify that the Engage server can be Pinged.

3. Check the network configuration (such as routing, traffic load, and so

on). Adjust the network configuration, if required.

4. There should be no broadcast or multicast activity on the TLAN .In-

terconnect a hub and a network analyzer to the TLAN and monitor for
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Symptom What to do...

such activity. Identify the source(s) and isolate them from the TLAN.

The TALC cannot establish a

connection with the Engage

server.

1. Verify security authentication configuration and ensure that it

matches at both ends. (For example, if security identifier is used,

ensure that the inbound and outbound security identifiers are cor-

rectly configured at each end.)

2. Ensure that the unit IDs have been correctly configured at each end.

An incorrect unit ID causes security authentication to fail.

3. Ensure that the TALC’s IP address is correctly configured on the

Engage server.

4. Verify that the IP network is operational (up and running) as appro-

priate.

5. Ensure that the TALC is enabled on the host PBX.

6. Use the Ping option in Configuration Manager to ping the Engage

server.

7. If the Engage server does not respond, check the network con-

figuration (such as routing, traffic load, and so on). Adjust the net-

work configuration, if required.

Delete this text and replace it with your own content.

12.3 Solving Software Problems

This section identifies some problems that can occur with the Configuration Manager software, and describes

what to do to resolve them.

Symptom Descriptions

If you are not able to complete a task with Configuration Manager, perform troubleshooting as described in

the following table:
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Symptom What to do...

The Configuration Manager software

installation fails.

Ensure that you close all background applications, including

anti-virus software, before performing the installation.

When performing one of the following

by TFTP, ERROR: FILE OPEN FAILED dis-

plays:

l configuration upload

l Engage firmware upgrade

1. Ensure that the TFTP server application is installed and run-

ning on the administration PC.

2. Ensure that the file you are trying to upload is present in the

target directory, that is, either in the TFTP directory, or in

the directory that is specified as the base directory in the

TFTP server application.

3. Reviewmessages displayed by the TFTP server application

for clues.

4. Ping the Engage server to verify that network connectivity

exists.

CONFIG UPLOAD FAILED displays

when attempting to perform a con-

figuration upload by TFTP.

1. Ensure that you selected anappropriate file. That is, ensure

that the file you attempted to upload is a TALC configuration

file.

2. Ensure that the configuration file you are attempting to

upload is compatible with current Engage firmware.

3. Perform the configuration upload using a previous con-

figuration file, if necessary

Note: Each time you perform a Engage firmware upgrade, you

should also create a backup of the configuration. The con-

figuration database format in the TALC is dependent on the ver-

sion of firmware installed on the TALC. If you recently

downgraded to a previous version of Engage firmware, you

may also need to revert to a previous configuration format.

System not responding displays when It is possible that communication has been lost between the
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Symptom What to do...

working with Configuration Manager. administration PC and the TALC.

Close Configuration Manager, and then restart it.

Nothing happens when attempting to

log off from the TALC.

It is possible that communication has been lost between the

administration PC and the TALC that you were logged on to.

Close Configuration Manager, and then restart it.

12.4 Using Configuration Manager PING

This section explains how to use the Ping option provided in Configuration Manager to verify connectivity.

Use this procedure as a troubleshooting tool to determine if you can reach all network TALCs, or any other

device on the network.

Perform a Configuration Manager PING

To perform a Configuration Manager PING:

1. From themenu, choose Tests → Ping. The PING Test dialog box displays:

2. Enter the IP Address of the TALC to be tested with a ping.

3. In theNumber of Cycles box, enter the number of times to ping the TALC. The number must be in the

range of 1 to 100.

4. Click on the OK button. The PING Test results dialog box displays PING results.
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5. Close the PING Test box.

12.5 TALC Card Traces and Commands

Access the TALC through Telnet client.

Go to Edit and hit Start Loggin

Give the file a name

In Debuf, type pf 2 port

Leave the session open so it logs all the calls on the port.

When the TALC card is ready to communicate, it displays:

TALC_RDY>

dc 0,s: Dumps the configuration of the card.

displog shows the events on the board (reset, login, connection to IDVR).

Description of dump elements:



ag160414 Copyright © 2016, TelStrat International, Ltd.
All rights reserved.

130

Ex. IPCFG 192.168.143.134, 255.255.255.0, 192.168.143.254, 0.0.0.0, 255.255.255.0, D

IP Address: 192.168.143.134

IP Network Mask: 255.255.255.0

IP Gateway: 192.168.143.254

Management IP Address: 0.0.0.0

Management IP Network Mask: 255.255.255.0

Ethernet Full Duplex [E-Enable D-Disable]: D

Ex. SYSCFG 1,IDVR Beta Card 1

Board ID: 1

Node Name: IDVR Beta Card 1

Ex. ACCFG E, 1, 04:00, 16, 0, 4728

Configuration name: accfg

DN Discovery[E/D]: E

DN Discovery Frequency [1-Per Day 2-Per Week 3-Per Month]: 1

DN Discovery Time [hh:mm]: 04:00

Extension to Dial - Port Number: 16

Extension to Dial - Feature Key: 0

Extension to Dial - DN: 4728
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Ex. PORTCFG 0, E, 1, D, D, N, D ,D

Port Number: 0

IDVR Status [E/D]: E

IDVR CompressionRate[0-G711 1-G723.1]: 1

TAPI Support [E/D]: D

2250Port[E/D]: D

Configure Agent ID ?[Y/N]: N

Beep Tone [E/D]: D

Virtual Phone Recording [E/D]: D

Ex. FKEYCFG 1,13 EREC ,14 ECS ,9 RDIS ,NC

Device Number: 1

Feature 1

KeyNo Feature Data: 13 EREC (record)

Feature 2

Key No Feature Data: 14 ECS (Conversation save)

Feature 3

Key No Feature Data: 9 RDIS (Delete Recording)

Feature 4
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Key No Feature Data: NC

Config commands

Attribute rc : Type rc before any of the following config commands and the system will print the current config

for that command.

Dm i

ip: set the IP address of Card

syscfg: set the unit ID, and Node Name

idvrcfg : enable, and set the IP address of server

accfg: set DNDiscovery

portcfg: configure a port

fkeycfg: configure key for port

sympdispcfg: symposium configuration

sc y: save configuration

sr 1,y : reset board

us: upload software

uc: upload configuration

DEBUG Commands and Suggestions

wh displays version number of the card and how long the card has been up

pf 4 (port 0 - 15) captures information sent between card & Phone
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pf 4 (port 32 - 47) captures information sent between card & PBX

cp 5 (port 0 – 15) snapshot of the phone

cp 085 <port> To see the DNDiscovery of the particular port

db 13 5 displays cross connect information

db 2 153 Call start information

db 2 154 detailed call start information

db 2 8 See DND discover run

db 2 184 Agent login

db 8 y IDVR StateMachine

db 2 026 Call StateMachine

cp 021 <port> To see the Call Bits for the port

cp 022 <port> To see the RSM (Recorder StateMachine) for the port – use it for recording problem

ES 1Network states

Dcb DSP information

NVD

CPP MADN enable disable

TMS (set in seconds) Time stamp (default 60 for 1minute)

Sdp 13 3 port Beep tone

Sdp 8 3 port ?
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sdp: Set Debug Print Level: Type (max=18), Level (max=3), Channel(max=31)

0 : Icon Control

1 : Connect ID

2 : Privacy Override

3 : Line Preference Key (LPK)

4 : Redundant_Indicator

5 : CP Virtual Device

6 : CP Call Handler

7 : CP Call StateMachine

8 : CP RSM Manager

9 : CP Recorder StateMachine

10 : IDVR Keys

11 : CPND StateMachine

12 : Softphone Hotline StateMachine

13: Recording Beep Tone

14 : ACD Call Force Tone

15 : Fast Path

16 : KBA Phase II From PBX

17 : Overlay

18 : DC IDVR Call Manager
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During a debug session, always do the following:

l When doing traces, annotate what the user is doing. Use special characters (ex. !, @, #, $, % etc.) to mark

the comments.

In debug window:

l wh: Get the version, how long the card has been up.

Before closing the debug window and while in theMMI window:

l dc: Get the config

l dlog: Get the display log

When a customer reports a problem, while communicating with them, always get:

l Card’s config

l TNB of the whole slot

l Symptoms of failure

l Exact date/time of failure

l Frequency of failures

l Finally, get a VERY detailed description describing exactly (as close as possible) what the user is doing
(ex. keys being pressed, how many times, lamp status whether on, off or blinking, and any other
symptoms) to generate the issue.

12.6 Catastrophic Failures

A catastrophic failure is defined as a failure of the equipment to operate after review of all troubleshooting

information and implementation of appropriate procedures.

Inoperative Hardware
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Should the TALC fail to operate after thorough troubleshooting and review if all test and system configuration

results, consult with the distributor for hardware replacement.
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